1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Psp 3003 ver 6.39

Discussion in 'Sony PSP - Mod and firmware discussion' started by Peterd22, Feb 5, 2012.

  1. Peterd22

    Peterd22 Member

    Joined:
    Feb 5, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    Complete newbie here. My son has a psp 3003 with sotfeware version 6.39 need pointing in right direction to upgrade/downgrade, must be a simple guide lol. Thanks in advance
     
  2. .XenoN

    .XenoN Member

    Joined:
    Feb 12, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    okay, so go to psp-hacks.com to get all these things (sorry, I can't link):

    psp-downgrader 6.xx
    psp 6.20 ofw
    psp 6.20 pro cfw and perma-patch

    1. put 6.20 ofw in downgrader folder named 620.pbp.
    2. run downgrader on psp (should be signed).
    3. when you're at 6.20 ofw run the pro cfw installer, for the first time you won't need to "fast recover".
    4. If you want actual cfw, run the perma-patch installer. Check compatibility, and if it's compatible, run the installer. Ignore the warnings, I have a 3000 and it's been 6.20 perma since the patch came out and I've been fine with it. *poof*, you have 6.20 cfw.
     
  3. Eisherz

    Eisherz Active member

    Joined:
    Nov 28, 2006
    Messages:
    2,832
    Likes Received:
    33
    Trophy Points:
    78
    No, just no. If that PSP came with firmware higher than 6.20 it's a non-fixable brick.
    Just update to 6.60 official and get 6.60 Pro-B (latest one, I think Pro-B9) from psp-hacks.com. It won't be permanent, but as long as you keep your PSP in standby mode that doesn't matter much. When you switch your PSP off completely it reverts back to official, you have to start the hack up again (don't know why people actually make such a fuss about that, that was quite common back in the DevHook days).
     
  4. .XenoN

    .XenoN Member

    Joined:
    Feb 12, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    No, just no. If you read the OP, he has psp 3003. 3003 shipped with 5.50 ofw, ending at 6.20 ofw. He would be perfectly safe with 6.20.
     
  5. Eisherz

    Eisherz Active member

    Joined:
    Nov 28, 2006
    Messages:
    2,832
    Likes Received:
    33
    Trophy Points:
    78
    You do realize that the 3003 is just a region code for UK PSPs? And I know that newer ones actually came with 6.39, don't know if there were ever PSPs delivered with 6.60, but I wouldn't take a bet on it.
     
  6. bigo93

    bigo93 Regular member

    Joined:
    Mar 11, 2008
    Messages:
    1,354
    Likes Received:
    0
    Trophy Points:
    46
    Hang on so psp 3000 models still cannot be permanently flashed on all firmware whilst other can? lol
     
  7. Eisherz

    Eisherz Active member

    Joined:
    Nov 28, 2006
    Messages:
    2,832
    Likes Received:
    33
    Trophy Points:
    78
    The so-called "unhackable" PSP 2000 (TA-088v3 mobo and up), the PSPGo and the PSP 3000 cannot be permanently flashed on all firmwares, only with the permanent patch for 6.20 pro, which then has a few less options than the permanent CFW.
     

Share This Page