1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PSP Downgrade from version 2.82

Discussion in 'Sony PSP - Mod and firmware discussion' started by kentwan, Mar 20, 2007.

  1. kentwan

    kentwan Guest

    I am having severe trouble downgrading from version 2.82 to 1.5. If anyone has any pointers please im open to suggestions. thanks
     
  2. smlvfx

    smlvfx Regular member

    Joined:
    Dec 9, 2006
    Messages:
    1,358
    Likes Received:
    0
    Trophy Points:
    46
    you need to upgrade to 3.03 and then downgrade to 1.5
    to downgrade from 3.03 you will need the original umd of the unpatched version of Grand Theft Auto Liberty City Stories.
    The unpatched version of the game that contains the 2.0 update

    you can find the downgraders guides here
    http://forums.qj.net/f-guides-hacks-homebrew-and-emulators-43.html/
    http://www.psp-hacks.com/file/1044

    make sure which motherboard you have some downgraders support all motherboards others dont,if you have a pink psp is a ta-086 motherboard
    http://forums.afterdawn.com/thread_view.cfm/369035
     
    Last edited: Mar 20, 2007
  3. MidnightJ

    MidnightJ Guest

    There is not suppose to be any discussion on downgrading and stuff on this forum section. READ the forum section description.
     
  4. eggtrip

    eggtrip Member

    Joined:
    Apr 10, 2007
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    how will i know what motherboard i have?
     
  5. MikehMike

    MikehMike Guest

    Turn your PSP upside-down, and open the UMD door. Look inside the UMD door to the green plasticy thing in the back. Look all the way on the left, if you see IC1003, then you have a TA-082 or a TA-086. If not you have a TA-079, -080, or -081.
     
  6. eggtrip

    eggtrip Member

    Joined:
    Apr 10, 2007
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    i have "IC1003" on the green thingy and am running a 2.82 version.
    is it safe to upgrade it to 3.03?
     
  7. eggtrip

    eggtrip Member

    Joined:
    Apr 10, 2007
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    ow.. what i mean is downgrade to 1.5. just like smlvfd said "upgrade to 3.03 and then downgrade to 1.5" since am using a "IC1003" can i downgrade it straight to 1.5? or should i follow the step by step?!
    am a noob,so am sorry if i keep on asking question. =S
     
  8. CKhaleel

    CKhaleel Regular member

    Joined:
    Feb 26, 2007
    Messages:
    1,669
    Likes Received:
    0
    Trophy Points:
    46
    Yes.
     
  9. CKhaleel

    CKhaleel Regular member

    Joined:
    Feb 26, 2007
    Messages:
    1,669
    Likes Received:
    0
    Trophy Points:
    46
    Oh yeah, you have TA-082. You're safe for everything. :)
     
  10. pspGenius

    pspGenius Guest

    I have just got the downgrader for version 3.11. It works and will go for a couple more test and will be released by me. I am currently woking on the downgrader for 3.30 and is almost down. Again I will have the link for 3.11 downgrader as well as instructions by tomorrow latest.
     
  11. eggtrip

    eggtrip Member

    Joined:
    Apr 10, 2007
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    HELL YEAH!!! i already downgrade my 2.82 to 1.5.thanks a lot guys. ahhmm...i have one more question.how can i put my wallpaper back?coz am looking for then "theme settings" and its not already there.=/
    how can i also play the homebrew game?do i still need to install other program?
     
  12. eggtrip

    eggtrip Member

    Joined:
    Apr 10, 2007
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    hey guys,i upgraded my psp to 3.03 OE - C. how can i play iso games?!='(
     
  13. gasconade

    gasconade Regular member

    Joined:
    Feb 17, 2007
    Messages:
    862
    Likes Received:
    0
    Trophy Points:
    26
    where else would it go...this is firmware discussion right? or was this thread moved?
     
  14. jokess

    jokess Guest

  15. trippy92

    trippy92 Regular member

    Joined:
    Mar 8, 2007
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    26
    ill test
     
  16. trippy92

    trippy92 Regular member

    Joined:
    Mar 8, 2007
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    26
    nope it just goes to other links
     
  17. PsPNuB

    PsPNuB Member

    Joined:
    Apr 19, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    i also have the 2.82, and wish to run the 3.03 oe-c. I opened the UMD tray and looked at the green mobo, and there is nothing on there. maybe im looking at the wrong spot. help?
     
  18. gacler

    gacler Member

    Joined:
    Apr 19, 2007
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    11
    Hello, I have this on the motherboard: ICB001 , and version 2.81 firmware, do I need the GTA disc to downgrade and run ISOs and emulators? thanks a lot.
     
  19. Ajallstar

    Ajallstar Member

    Joined:
    Apr 21, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    11
    I got the thing to 3.03 HEN and the downgrade program won't run without an "update.pbp" HELP PLZ!!!!!!!
     
  20. MidnightJ

    MidnightJ Guest

    That was my mistake. Orignally before i posted that it said it was in the Xbox 360 General Discussion for some reason.
     

Share This Page