1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PSP Firmware

Discussion in 'Sony Handhelds' started by ukgtitch, Mar 4, 2007.

  1. ukgtitch

    ukgtitch Member

    Joined:
    Feb 21, 2007
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    16
    Hi, i've just purchased a PSP i guess this is going to have the latest firmware with it.

    Say if the firmware is 2.7 or something, can i still downgrade to 1.5? or does the 2.0 firmware only support the downgrader thanks! is it really worth downgrading to 1.5 and risk my new psp being bricked? thanks..
     
    Last edited: Mar 4, 2007
  2. WierdName

    WierdName Regular member

    Joined:
    Jun 11, 2013
    Messages:
    912
    Likes Received:
    0
    Trophy Points:
    26
    First of all, what firmware does it currently have? That is a big factor for downgrading. I think up to 2.80, you can downgrade without an unpatched GTA: LCS UMD. And downgrading has a slight chance of brickage but not much.
     
  3. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
    well if u just got a new psp, and brick it, u can just return it and get a new one.

    the only versions that can be downgraded are 2.0 to 2.80, and 3.03, but with 3.03 weirdname said, it needs an unpatched version of GTA LCS and those are hard to find now, everyone wants one to downgrade
     
  4. ukgtitch

    ukgtitch Member

    Joined:
    Feb 21, 2007
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    16
    Is there much difference other than being able to play games from a memory stick from 1.5 to 3.03?

    Is version 1.5 the only firmware that lets you do this? or is there an easier and better version of the firmware that also lets you run games from the memory stick?

    Don't get me wrong i'd love to play any game that i downloaded from the net but i don't really want to brick my psp after an hour of recieving it!

    2.8 firmware btw thanks.
     
    Last edited: Mar 5, 2007
  5. Vaindetta

    Vaindetta Regular member

    Joined:
    Feb 23, 2007
    Messages:
    227
    Likes Received:
    0
    Trophy Points:
    26
    You need to upgrade to 3.03 then downgrade to 1.5, from there you can install custom firmware 3.03 OE-C and run homebrew that supports NES, SNES, Sega/Master System, Sega Gamegear, Gameboy/Color, Gameboy Advance, Doom for PC, UMD ISOs, and PS1 Eboots and .bins.
     
  6. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
    NO DO NOT UPGRADE TO 3.03. there is a downgrader for 2.80 to downgrade to 1.5, then u can upgrade to 3.03 oe-c. u don't need to upgrade to 3.03
     
  7. Vaindetta

    Vaindetta Regular member

    Joined:
    Feb 23, 2007
    Messages:
    227
    Likes Received:
    0
    Trophy Points:
    26
    the 3.03 comes with a patcher incase the psp has a TA-082+ board in it, wasnt sure about the 2.80 downgrader.
     

Share This Page