1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PSP ISO not loading??

Discussion in 'Sony PSP - Homebrew software' started by fish2121, Jun 20, 2007.

  1. fish2121

    fish2121 Member

    Joined:
    Apr 12, 2007
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    Hi guys, dont know if anyone else has a thread similar but anyway....

    I downloaded an ISO game (uefa champions league to be specific) i extracted the RAR file so that i was left with an ISO/CSO. The game shows up on my memory stick and when i click to open it the PSP logo screen appears but then the screen goes black and the console freezes. Can anyone help me please??

    FW is 3.03 OE-C

    Thank You!
     
  2. hodgins91

    hodgins91 Regular member

    Joined:
    Jun 10, 2006
    Messages:
    3,636
    Likes Received:
    0
    Trophy Points:
    46
    have you got an original UMD in the drive ?
     
  3. dEEz_nUtz

    dEEz_nUtz Regular member

    Joined:
    Sep 10, 2006
    Messages:
    1,798
    Likes Received:
    0
    Trophy Points:
    46
    could be a bad or corrupted ISO also..you will find that its best to just try downloading a different one rather than racking your brain over a non-working one..
     
  4. fish2121

    fish2121 Member

    Joined:
    Apr 12, 2007
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    Ye its an original UMD. Your probs right it took less than two hours to download anyway so i'll try find another one.

    Thanks for helpin ppl :D
     
  5. drakex

    drakex Regular member

    Joined:
    May 19, 2007
    Messages:
    893
    Likes Received:
    0
    Trophy Points:
    26
    What he meant is if you have an Original UMD (any) inside, cause not all the games work without UMD, I guess that is the most common error.
     
  6. dEEz_nUtz

    dEEz_nUtz Regular member

    Joined:
    Sep 10, 2006
    Messages:
    1,798
    Likes Received:
    0
    Trophy Points:
    46
    ...an original game UMD that is..movies dont work-but if you are getting past the PSP splash screen, and then the screen goes black and shuts off-that usually means a bad ISO
     
  7. jwc75

    jwc75 Member

    Joined:
    Jun 18, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    i have the same problem i dont know what to do i do have orig umd i tried umdemulator doesnt work, im tryin the rainbow six vegas, metal gear solid, shrek it all wont work. pls help
     
  8. dEEz_nUtz

    dEEz_nUtz Regular member

    Joined:
    Sep 10, 2006
    Messages:
    1,798
    Likes Received:
    0
    Trophy Points:
    46
    @jwc75-what firmware are you currently using? because if you have custom firmware, theres no need for umdemulator. Also rainbow6 and shrek are pretty new games, so they will require a higher FW. post back with your firmware version-
     
  9. jwc75

    jwc75 Member

    Joined:
    Jun 18, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    @dEEz_nUtz i have fw 3.03 oec
     
  10. zappp64

    zappp64 Regular member

    Joined:
    Oct 13, 2005
    Messages:
    642
    Likes Received:
    0
    Trophy Points:
    26
    you need to go into recovery menu (start up PSP and hold down R trigger until blue screen appears) go to Configuration then ensure NO UMD is set to disabled - save settings and start up PSP - have a game UMD in drive. game should load up.

    also another point, make sure the ISO filename is less than 15 characters long with no spaces.

    I have the above mentioned game and CSO works without any problems.
     
  11. jwc75

    jwc75 Member

    Joined:
    Jun 18, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    @zapp thank you soooooooo much! i didnt know i have to rename the file thats all i have to do and it worked!!! thank you sooooo soooo much for your help.
     

Share This Page