1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Psp - no video, green light with sounds

Discussion in 'Sony PSP - Mod and firmware discussion' started by HellSpun, Mar 29, 2007.

  1. HellSpun

    HellSpun Member

    Joined:
    Mar 29, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    My first post btw -- here goes: I cracked the LCD on my psp. I figured while I had it open and since I was invalidating warranty I would mod it up, so I ordered a clear case (full body) with my screen. I tested the LCD before I started pulling the rest of the parts out and it worked fine. When I got everything together in the new case my psp had blank screen (no backlight - looks like its off), green light, but no sound and had to remove battery to turn off. I took it apart again, reassembled and now I have blank screen (no backlight - looks like its off) but get green light and sound - pressing dpad makes sound of navigating thru menus (glad I left the annoying click on last time I flashed). I reinstall the borken LCD and now it is blank - it was working just with a big ugly scrack in the middle. This is running 3.03 custom firmware of some flavor. I have tried running a recovery (even thou I can't see screen I remebered how the navigate to it - I confirmed this with my mem card reading and system powering off) and the brightness button did nothing. Is this something I can fix? I bumped into a post about backlight fuse and solder bridging it if it blows but the pictures showing location of fuse were linked on a russian forum that I could not quite finish the registration process on. Any ideas or help is appreciated. I want to try and salvage it or confirm that a new motherboard is what is needed before I start throwing money around.

    Thanks ahead of time,
     
  2. HellSpun

    HellSpun Member

    Joined:
    Mar 29, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Nevermind! - did more poking around on the net and found its voltage - its labeled right on the board. Btw a test bridge with my screwdriver and BOOYAH! backlight is back - time to bust out the solder and hope I can get just enough on there and not pooch it up! The backlight fuse is the one right below the gold plate where 2 screws go in - it says 0.5A between that gold box and the fuse. Hope this helps someone else in the future!

     
  3. bagpuss69

    bagpuss69 Guest

    HellSpun
    I too have this problem,could you post details on how you fixed this problem, with pics if you have them,
    TIA
     
  4. psphak8o8

    psphak8o8 Regular member

    Joined:
    Jan 13, 2007
    Messages:
    187
    Likes Received:
    0
    Trophy Points:
    26
    Hey i need help to I just crack my screen....
     
  5. HellSpun

    HellSpun Member

    Joined:
    Mar 29, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Well I fixed that but apparently I have another problem - one of the gears on my UMD fell off and now it wont move the laser head left or right, so I had to order a replacement. I also put a screw thru one of my speaker wires so I had to order a set of those too.

    My PSP is all screwed together atm but as soon as I get my parts (less then a week - I paid extra and bought from someone in my country)I will take some pictures. With the UMD out I can't get ISO's to work so far but atleast its a video / mp3 player again.

    Watch for a reply within the next week. In the mean time you should get a few tools together. You will need a multimeter, a decent small tipped soldering iron, electrical solder (I used fluxless solder but I had to do the job twice - first time it knocked off in reassembly) and the most important tool - a #000 screwdriver. The smallest I could find was a #0 and I ended up stripping some screw heads out.
     

Share This Page