1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

psp-usb connection problems

Discussion in 'Sony PSP - Mod and firmware discussion' started by smeagle, Dec 28, 2005.

  1. smeagle

    smeagle Member

    Joined:
    Jun 25, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    11
    Hi.I am having trouble connecting my psp to my pc.
    Everytime I connect my psp to my pc-using the data transfer cable,my pc freezes.I have tried updating the firmware from 1.52 to 2.0,but the problem persists.
    I also purchased another data transfer cable,but this didn`t seem to work either.Nor did using a usb cable from a digital camera.
    I am unsure whether it is a driver issue,a windows xp issue or a psp issue.
    I really want to use the 2.0-1.5 downgrader so any help would be appreciated
  2. AfterDawn

    AfterDawn Advertisement

  3. RavenLife

    RavenLife Regular member

    Joined:
    Oct 2, 2005
    Messages:
    1,707
    Likes Received:
    0
    Trophy Points:
    46
    I think most likely its your pc rather than psp

    first of all try your psp on someone elses computer (just to rule that out completely)

    2. update your drivers

    3. try again - if it still doesnt work try a differnt usb connection. one at the back of your comp would be most advisable (this should rule out a pc problem.

    4 if it doesnt work on a mates comp or yours after you have updated it is your psp you should return it if yuo just got it
  4. smeagle

    smeagle Member

    Joined:
    Jun 25, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    11
    Thanks Ravenlife,I will try it on another pc over the weekend!
  5. steve191

    steve191 Regular member

    Joined:
    Dec 3, 2005
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    26
    I had this problem aswell...

    I fixed it by unplugging every other USB device and plugging in the PSP on it's own.
  6. smeagle

    smeagle Member

    Joined:
    Jun 25, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    11
    Steve191-Thanks for the advice...I unplugged all other usb cables to my pc & connected the psp.
    The computer froze again-so I switched the computer off at the wall, without restarting-but when it restarted-I was able to go into usb mode without the computer freezing.
    Now, I am working on getting my pc to recognise the psp as a removable storage device in my computer.
    I will search through the forums to hopefully find a solution
  7. steve191

    steve191 Regular member

    Joined:
    Dec 3, 2005
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    26
    Yeah...forgot to mention to restart your pc.

    If your running windows XP it should install itself.
  8. smeagle

    smeagle Member

    Joined:
    Jun 25, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    11
    Hi all,
    I finally found the cause of this problem:
    Whenever I connected usb 2.0 hardware to my system(psp,digital cameras,external hdd`s)to name a few-My system would lock up and freeze,forcing me to switch the computer off at the wall.
    Sometimes I would connect usb devices that would not cause the pc to lock up-but they would not appear in "My Computer"and would not be recognised by windows.
    I searched a sh*t load of forums for a few frustrating weeks,and tried alot of different methods,uninstalling devices,updating/rolling back drivers,checking for short circuits,power surges,reinstalling windows,defragmenting my drives,BIOS flashing...etc.Nothing seemed to work.
    All I did was buy a new PCI usb 2.0 card(no AGP ports on my PC)with a seperate usb controller.
    The onboard usb controller & ports attached to my motherboard were apparently usb 2.0 compatible,but were the reason usb 2.0 devices would fail.
    The new usb controller on the pci card proved to be the solution to a seemingly frustrating situation.Now all usb devices are working fine :)
  9. N0_0ne

    N0_0ne Regular member

    Joined:
    Oct 10, 2005
    Messages:
    253
    Likes Received:
    0
    Trophy Points:
    26
    I have a different yet similar problem, when I connect my psp to my comp via usb everything is normal (new hardware found etc..) but within 1 minute or so the screen showing the psp memory card(G:/ in my case) dissapears then a few seconds later reappears leaving my no time to transfer the iso image, also I get an icon in the bottom right hand corner called "safely remove hardware" , Im not sure what the problem is, Ive tried different cords and different usb ports, plz help I have tons of games I want to get to,

    thx in advance

    N0_0ne
  10. Codeman74

    Codeman74 Regular member

    Joined:
    Dec 25, 2005
    Messages:
    961
    Likes Received:
    0
    Trophy Points:
    26
    with the "safley remove hardware" thats fine. just go and click on it the press "stop", and "ok". I don't know what this does, but it did help me from bricking my psp. and about everything else, im sorry man can't help there.
  11. N0_0ne

    N0_0ne Regular member

    Joined:
    Oct 10, 2005
    Messages:
    253
    Likes Received:
    0
    Trophy Points:
    26
    Ok, I clicked close then ok but then the G:/ window dissappears and I cant find it within "my computer", seems that gets it ready for removal when what I want is it to stay connected longer then 1 minute, Im guessing this problem is something very simple cause Im new at this
  12. tarang

    tarang Member

    Joined:
    Jan 9, 2006
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    16
    thiz happened to me 2, and i jus restart my comp, and it starts workin

Share This Page