1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

psp v2.71 or higher

Discussion in 'Sony PSP - Mod and firmware discussion' started by moe12, Mar 26, 2007.

  1. moe12

    moe12 Guest

    iam gonna get a psp in versions 2.71 or higher but then can i play downloaded games on it??? like without using some modifications on the psp
     
  2. CoRn3tTo

    CoRn3tTo Regular member

    Joined:
    Feb 16, 2007
    Messages:
    172
    Likes Received:
    0
    Trophy Points:
    26
    2.71 is enough,,,don't get enough higher than that coz ul be complicated on downgrading,,, get 2.71 and downgrade to 1.5 (so you can get to play downloaded games) better yet after going to 1.5....you can upgrade to custom firmware like 3.03oe-c or 3,10oe-a in 3.03oe-c you can customize yor psp while in 3.10oe-a is less cuztomizable
     

Share This Page