1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

psp v2.8.0 do I need gta :lcs to downgrade?

Discussion in 'Sony PSP - Mod and firmware discussion' started by bondage81, Feb 11, 2007.

  1. bondage81

    bondage81 Member

    Joined:
    Dec 16, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    16
    I am fixing to buy a psp v2.8.0 do I need gta :lcs to downgrade?
     
  2. tehjoker

    tehjoker Regular member

    Joined:
    Sep 15, 2006
    Messages:
    1,037
    Likes Received:
    0
    Trophy Points:
    46
    did you search this before? because only the 3.03 downgrader uses an unpatched gta lcs...
     

Share This Page