1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PSP v2.8 with TA-082

Discussion in 'Sony PSP - Mod and firmware discussion' started by markop123, May 22, 2007.

  1. markop123

    markop123 Member

    Joined:
    Mar 17, 2006
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    Hi,
    I have 2 psps with v2.8 f/w and TA-082 mobos. I would like to downgrade to v1.5 and upgrade to v3.03oec but I read in the "motherload of psp guides" that there is a strong chance of bricking psps with these mobos. What are my options? I would also like to be able to backup my games.

    Thanks
     
    Last edited: May 22, 2007
  2. SMARTYP

    SMARTYP Regular member

    Joined:
    May 22, 2007
    Messages:
    127
    Likes Received:
    0
    Trophy Points:
    26
    hi markop123
    well wot ive heard and seen i dont think its possible at all to downgrade a ta-082 m/b with 2.8 but is possible with 2.71 as i did it with mine

    smartyp
     
  3. markop123

    markop123 Member

    Joined:
    Mar 17, 2006
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    Would it work if I upgraded to 3.03?
     

Share This Page