1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

psp version 3.40

Discussion in 'Sony Handhelds' started by cosotas, May 11, 2007.

  1. cosotas

    cosotas Member

    Joined:
    May 11, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    which program do i have to download so i can play ISO games in version 3.40 on my psp...
     
  2. blackvamp

    blackvamp Regular member

    Joined:
    May 3, 2007
    Messages:
    1,173
    Likes Received:
    0
    Trophy Points:
    46
    you can't. there's absolutely nothing you can do.
     
  3. jackfood

    jackfood Regular member

    Joined:
    Jun 2, 2005
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    26
    You need a downgrader in order to play ISO.
     
  4. blackvamp

    blackvamp Regular member

    Joined:
    May 3, 2007
    Messages:
    1,173
    Likes Received:
    0
    Trophy Points:
    46
    I know you are trying to help, but it's useless to bring it up. There isn't one. And will not be one for a long while.
     
  5. cosotas

    cosotas Member

    Joined:
    May 11, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    whatt iss a downgrader..?? could somebodyy tell mee plzz.. causee i need to know, and also to know which one do i need to play ISO in version 3.40 ... plzzz help.. urgent.. :D
     
  6. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
    OK, cosotas, you can't play ISOs on a 3.40, period. There isn't a downgrader for 3.40.

    and as for the definition, why can't you just look it up
     
  7. unfeared

    unfeared Member

    Joined:
    May 11, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    there is no downgrader, but u can use recovery to get to 1.50 and then update to any fw
     
  8. jackfood

    jackfood Regular member

    Joined:
    Jun 2, 2005
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    26
    PSP 3.11 is quite hard to crack by using software alone as SONY covers the loopholes. Modchip may be needed in future.

    However, you can still play games on PSP 3.11, 3.30 and 3.40 perfectly without any problem. Is all depend on you.
     
  9. glenquag

    glenquag Regular member

    Joined:
    Mar 7, 2007
    Messages:
    1,879
    Likes Received:
    0
    Trophy Points:
    46
    Wow...
     
  10. jackfood

    jackfood Regular member

    Joined:
    Jun 2, 2005
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    26
    There is still hope for 3.11 and above to play homebrew.
     

Share This Page