1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pstwo not working...no modd

Discussion in 'PS2' started by motoxthor, Dec 13, 2004.

  1. motoxthor

    motoxthor Guest

    my pstwo just stopped working. havent done ANYTHING to it. i heard of a recall rumor...this happen to anyone else?
    thnx
     
  2. succubus

    succubus Member

    Joined:
    Nov 21, 2004
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    16
    mine still works, and i modded mine
     
  3. billz

    billz Active member

    Joined:
    May 12, 2003
    Messages:
    1,064
    Likes Received:
    0
    Trophy Points:
    66
    plenty do a google search...best advice take it back and get a new one
     
  4. yudda111

    yudda111 Guest

    i did the softmod too and it work i even fuckup the internal switch with too much glue but i fix it by soldering something and it work perfect.
     
  5. Maryela3

    Maryela3 Guest

    yo homz mine souND really weird and its not modded either i press the little green button and bang!! TRACKA TRACKA TRAKCA then it opens.
    Now i insertthe CD press the green button again and the same the tracka tracka noise the disc goes inside the Ps2 and i just recieve the Red screen that says Disc is not valid ur somethin like dat
    Do anybody know whats wrong?? can i fix it by myself i already modded 3 Ps2 no problems so far.
    I think the problem is bein the whole Reader unit shall i change it or take it to some guys that know more than i do Pleaze help!! i miss my GTASA i havent finished yet!!!
    Maria=)
     
  6. motoxthor

    motoxthor Guest

    ya i might take it back, i still got a warranty, havent opened it up yet. it pisses me off tho more than anything that they are jsut breaking for no reason now.
     
  7. easy123

    easy123 Member

    Joined:
    Dec 2, 2004
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    16
    hey succubus, where did you buy your pstwo from? is it a PAL or NTSC PSTWO? And what chip did you install? Model number?
     

Share This Page