1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PStwo V12 Magic 5KX Install Help

Discussion in 'PS2' started by nosferatu, Dec 1, 2004.

  1. nosferatu

    nosferatu Member

    Joined:
    Dec 24, 2002
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    11
    Alright,

    I've been doing this for 4 years or so and I've had problems like this before... so I was hoping someone could point me in the right direction for some help.

    I can't solder the ground point for the V12 Magic 5KX chip, it just won't take. I have resin, different solder irons and everything... but it won't take to the ground point. Is there an alternate ground point that you have used for the V12? Please give me a clue, I'm just going off the instructions from China Magic for my install.

    Thanks,

    Kimo
     
  2. nosferatu

    nosferatu Member

    Joined:
    Dec 24, 2002
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    11
    any help for someone else who has done this before? Thanks!
     
  3. Jixxer

    Jixxer Member

    Joined:
    Dec 7, 2004
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    11
    You have to lightly scratch the surface of the copper you are soldering to....or use some sand paper....I just use a knife...then add a little flux to the surface...then solder away...the board is coated with some green crap...you just got to get down to the metal first for it to stick!!! Enjoy !!
     
  4. nosferatu

    nosferatu Member

    Joined:
    Dec 24, 2002
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    11
    I appreciate the help, but I found the solution. To use a different ground. The ground I was referring to was not a copper based ground, nor was it on the board that you scrape off.

    I just used one of the copper rectangles from another chips directions instead, my new slimline PStwo's boot like a champ. Yay.
     
  5. easy123

    easy123 Member

    Joined:
    Dec 2, 2004
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    16
    i thought the pstwo burns up after installing a modchip? BTW, where did you buy the chip?
     
  6. nosferatu

    nosferatu Member

    Joined:
    Dec 24, 2002
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    11
    No, the first gen chips did... but the Magic ones have no problems for the last... oh, 14 days of playing this one.

    There are many places that *should* carry the Magic 5KX chip, just can't say where I got mine =P

    Good luck.
     
  7. easy123

    easy123 Member

    Joined:
    Dec 2, 2004
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    16
    just heard some news about Magic no longer producing their chips and all the chips available are clones...
    also some guy said his PSTWO stopped loading after a few months after installing the new chip..........
     
  8. easy123

    easy123 Member

    Joined:
    Dec 2, 2004
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    16
    btw, can you take a picture of how you arrange the wires, and which wire to use, and how you position the chip on the PSTWO mobo??
     

Share This Page