1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PSX games work, but with no video..??

Discussion in 'PS2 - CD backup discussion' started by Davood, Sep 6, 2007.

  1. Davood

    Davood Member

    Joined:
    Sep 6, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Is this due to bad media?

    I'm playing them on a ps2 modded with a modbo 745.

    some games work fine like star ocean 2, but some games like legend of mana just play the music, and let me interact with the game (I can play the game just fine, with an emu loaded alongside on a pc to "guide" my actions i can actually plat the game), these games display a black screen (nothing) but otherwise "Work".... is this a burning problem? or a rom problem? or a bad modchip?

    i'm using fairly decent cd media I think and burning at x4 and using the .ccd image with alcohol 120
     
  2. Davood

    Davood Member

    Joined:
    Sep 6, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    and for the record i searched in the forums+google and did not find the answer.. so either my powers are weak or maybe this is a UBF and i need help identifying that. or maybe its a valid problem haha.
     
  3. smokyrain

    smokyrain Senior member

    Joined:
    Sep 15, 2006
    Messages:
    5,207
    Likes Received:
    6
    Trophy Points:
    118
    The black screen is usually a region error. PAL/NTSC
    Not sure with your type of modchip if theres a button you press to fix that or not.
     
    Last edited: Sep 6, 2007
  4. Davood

    Davood Member

    Joined:
    Sep 6, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    these were NTSC images... some of them had working video and some didn't... i'm using taiyo yuden CD-R media burning at x4

    all of them had working sound, and the games played, just without video.. which is weird.
     
  5. Davood

    Davood Member

    Joined:
    Sep 6, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    resolved my problem... ps1 games don't work with composite video (wtf?) just plugged it in using s-video and it worked fine.
     
  6. smokyrain

    smokyrain Senior member

    Joined:
    Sep 15, 2006
    Messages:
    5,207
    Likes Received:
    6
    Trophy Points:
    118
    Yeah I don't know unless its just some games or bad connection.
    Glad you got it sorted by using the s-video cable though.
     

Share This Page