1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pulldown

Discussion in 'Video to DVD' started by jhart999, Mar 15, 2005.

  1. jhart999

    jhart999 Member

    Joined:
    Mar 15, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Hi folks,

    I am having problems authoring an M2V converted from AVI. The source is an XViD encoded AVI at 23.976fps (NTSC) with a frame count of 191,512. So at 23.976 this gives a runtime of 133.13 minutes:

    191,512 frames / 60 seconds / 23.976 fps = 133.13 minutes

    However, when I author the DVD it comes out as much shorter because it's being authored at 29.97 fps:

    191,512 frames / 60 seconds / 29.97 fps = 106.50 minutes

    Somehow the audio synchs up with the video (even though the AC3 has an independent runtime of the original 133.13 minutes), so I suppose it's not all bad. But I want to maintain the original length, particularly because it's becomming a challenge now :)

    I understand that I am supposed to apply a pulldown on the M2V before authoring but I can't for the life of me get it to work :( Any advice on using pulldown (specifically the PullDown application found here would be awesome!

    I'll summarise what I'm doing but I can't provide app version numbers since I'm not at my home PC right now. I can provide them later.

    I use GSpot to find out the runtime, fps and origin of the AVI. Then I use the runtime to work out the bitrates (average and maximum) using this.

    Then I run CCE SP and drag my AVS script into it (having made sure my calculations are correct for the origin e.g. in this case NTSC, hence width = 720, height = 480).

    Before hitting Encode Now I edit the settings a bit. I'm not sure exactly what's pertinent here and I can't remember it all (again I can elaborate later). But I definitely make sure that the fps is set at 23.976 (and then the width/height is automatically 720/480). I enter the average/minmum (zero)/maximum bitrates that I found earlier. There are two options for pulldown (you have to choose one of them): 2:3 or 3:2. I've tried both.

    Then several hours later (since I choose VBR!) I have my MPV and VAF file (I leave the audio to VirtualDub). I rename the MPV to M2V and run IfoEdit and choose to Author a DVD. I open the M2V and the AC3 (converted using BeSweet from the WAV made in VirtualDub) and also a celltimes textfile to mark the chapters.

    When it gets authoring I see that the 'Picture Rate' is 29.97 which clearly explains where the problem arises. So I apply PullDown to the M2V and the new M2V does author at 23.976 but it's still too short!!

    The thing is I don't think I am using PullDown correctly. As far as I can remember what I would expect to work is this (entered at the command prompt):

    pulldown source.m2v target.m2v -framerate 23.976

    I've tried countless other things with the various options but I never get anywhere! Please, if anyone knows what to do, put me out of my misery :)

    Cheers,

    John
     
  2. vurbal

    vurbal Administrator Staff Member

    Joined:
    Nov 30, 2002
    Messages:
    3,102
    Likes Received:
    0
    Trophy Points:
    66
    First off if the source is an Xvid at 23.976fps you don't need to do anything in CCE for it. CCE's options are for pulldown detection so it can IVTC. Your source shouldn't have any pulldown so it's not an issue.

    You also shouldn't need any framerate arguments for pulldown. Just pulldown source.m2v destination.m2v should be plenty. You can also get PulldownGUI to go with it or a completely different program called DoPulldown that already has a GUI. Also DVD-Lab will apply pulldown flags for you if you import a video stream with a framerate of 23.976fps. If you don't have any luck with the other pulldown apps you could download the trial for it.
     
  3. jhart999

    jhart999 Member

    Joined:
    Mar 15, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Thanks for replying, vurbal =) Like I said, with respect to CCE SP and pulldown: with the frame rate set to 23.976 fps and hence the size at 720*480, by default the pulldown option is checked (and cannot be unchecked) and is set to 2:3. Are you saying I somehow need to uncheck the pulldown option?

    Also, I was originally using the PullDownGUI on top of PullDown but I found it restrictive (especially since changing the options sometimes stopped it from processing at all...).

    I did suspect that all I should be doing was specifying the source and the destination because that's what the default is the in GUI and from the instructions I had, I was only told to use the defaults. But obviously that doesn't work either :(

    So perhaps I should try some alternative pulldown applications. Thanks for the recommendations!

     
  4. vurbal

    vurbal Administrator Staff Member

    Joined:
    Nov 30, 2002
    Messages:
    3,102
    Likes Received:
    0
    Trophy Points:
    66
    Were you using the DVD compliant option in CCE? I've never used it but I could see it making pulldown a requirement. IIRC the DVD Compliant option is a bad idea anyway so I wouldn't use it. If CCE were putting in the flags I imagine Pulldown.exe would have problems with it.
     
    Last edited: Mar 15, 2005
  5. jhart999

    jhart999 Member

    Joined:
    Mar 15, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    vurbal, thanks again :) The guide I used did tell me to use the DVD Compliant option but I couldn't find it in the version of CCE SP I have. When I get back to my home PC I'll have a look.
     
    Last edited: Mar 15, 2005
  6. vurbal

    vurbal Administrator Staff Member

    Joined:
    Nov 30, 2002
    Messages:
    3,102
    Likes Received:
    0
    Trophy Points:
    66
    I just noticed that you're using IfoEdit which I don't recommend doing for NTSC. You can use Rejig, which has the same interface but works fine with NTSC. I'm not sure what version of CCE you're using, but the most recent version of CCE Basic doesn't have an actual DVD Compliant option any more. Instead it has a DVD option for the output type. If your version has that make sure you just select MPEG-2 instead so it won't try to enforce any kind of restrictions on you. Some will be things you don't need or want (like closing all GOPs if I remember correctly). I haven't read through the manual in a couple versions (when they still have the DVD Compliant checkbox) so I could be wrong about that.
     
  7. jhart999

    jhart999 Member

    Joined:
    Mar 15, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Okay, I see that, in CCE SP, if I deselect "for DVD" in Mode (and still maintain MPEG-2, of course), I can also deselect Pulldown. So first things first I'll give that a whirl, but it will take a while :(
     
  8. jhart999

    jhart999 Member

    Joined:
    Mar 15, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    So it still didn't work :(

    But I didn't perform a pulldown on the M2V before authoring so perhaps if I do that, this time it might finally work. We'll have to wait and see... damn work!!
     
  9. vurbal

    vurbal Administrator Staff Member

    Joined:
    Nov 30, 2002
    Messages:
    3,102
    Likes Received:
    0
    Trophy Points:
    66
    Yes you'll want to do the pulldown yourself. You should be able to do that with Pulldown or DoPulldown.
     
  10. jhart999

    jhart999 Member

    Joined:
    Mar 15, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    What confused me, vurbal, was that IfoEdit said it was authoring at a frame rate of 23.976, so I got all excited. I should have known better! Oh well, when I get home I'll give PullDown another go :)
     
  11. jhart999

    jhart999 Member

    Joined:
    Mar 15, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Okay, I'm still not having any joy with IfoEdit. So I have given Rejig a shot and the results are interesting. I've just authored a DVD with a pulled-down M2V and it ran at the correct speed. Awesome... except it's only just half the runtime it should be (1 hour 8 minutes 10 seconds to be precise).

    What's going on here?! My head hurts :(
     
  12. jhart999

    jhart999 Member

    Joined:
    Mar 15, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Alright, getting sad now - replying to my reply to my own reply =)

    But anyway, I figured the reason why the film was cut short was because my celltimes (chapter markers) weren't compatible with the way the DVD was being authored.

    So I authored again without celltimes and sure enough it worked!! So now I've got to use trial and error to sort out the chapters.

    Thanks for all your help, vurbal. It would seem the moral of the story is - as you said - that IfoEdit and NTSC don't get along. Rejig does the job (I'm off to review it!)
     

Share This Page