1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Quick question.

Discussion in 'Sony PSP - Mod and firmware discussion' started by JPS3, Jun 8, 2007.

  1. JPS3

    JPS3 Member

    Joined:
    Jun 8, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    Hi, I have a brand new PSP with a TA-082 that has firmware version 2.60

    I have an unpatched version of GTA:LCS. What is my best option for downgrading the PSP? Should I upgrade to 3.03 then use LCS to downgrade? That seems to be the safest route, with the patch built in and everything. Or, is there some other way that will patch the PSP, and let me use custom firmwares and everything? What do you guys suggest?
     
  2. glenquag

    glenquag Regular member

    Joined:
    Mar 7, 2007
    Messages:
    1,879
    Likes Received:
    0
    Trophy Points:
    46
    I say use the 3.03 downgrader. I've downgraded 2 PSP's with it and both passed with flying colors.
     
  3. JPS3

    JPS3 Member

    Joined:
    Jun 8, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    That's what I was thinking. It seems to be the most "fool-proof". I was into the homebrew scene early in the PSP's life, but dropped out of it for quite some time. With all that the community has done and put together since then though... I needed to have a homebrew capable PSP again.

    Thanks for the reply.
     

Share This Page