1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SATA DVD-RW drive not seen by Windows XP

Discussion in 'Windows - General discussion' started by scruff311, Dec 1, 2007.

  1. scruff311

    scruff311 Member

    Joined:
    Nov 30, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    I just got a LITE-ON LH-20A1S SATA DVD-RW drive yesterday and hooked it up. My BIOS detects it and I have enabled the SATA ports. My motherboard is an ABIT IS7-V2. The setting for enabling the SATA is called 'Enchanced' mode where SATA port 1 is referred to as IDE-3 Master. The problem is that when I boot up windows, it doesn't even know my new DVD-RW exists. What could possibly be the problem here? Usually windows will display 'Found new hardware' followed by 'Your hardware is installed and ready to use' at which point i can update the firmware and be ready to roll. This is my first SATA device I've ever tried to use on this computer so I don't have any prior experience with them. Help would be much appreciated. Thanks!
     
  2. QuikDraw

    QuikDraw Regular member

    Joined:
    Sep 29, 2007
    Messages:
    827
    Likes Received:
    0
    Trophy Points:
    26
    Is the light on the drive showing on at the BIOS screen? Do you know what I mean? The BIOS finds all the drives at boot and displays them on the black boot screen. This is the first place I look in an attempt to discern the problem.
    Go to device manager and do a scan for hardware changes and see if the new drive is picked up.
     
    Last edited: Dec 3, 2007

Share This Page