1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sonic Rivals on 1.5

Discussion in 'Sony PSP - Mod and firmware discussion' started by alexsc, Jan 21, 2007.

  1. alexsc

    alexsc Member

    Joined:
    Nov 6, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    Im gonna get yelled at for this thread, but I HAVE SEARCHED. I am having problems running my sonic iso on my 1.5v psp. I have tried umd emulator 0.8C, fastloader 7, nothing will run it. I get a frozen screen, or it goes black. Can someone help? I know its a newer game, 2.8 firmware requirment, so can someone help point me in the right direction? thankyou.
     
  2. rsrepp

    rsrepp Regular member

    Joined:
    Sep 3, 2006
    Messages:
    396
    Likes Received:
    0
    Trophy Points:
    26
    Your answer lies in Devhook .51 or 3.03 OE-B. Devhook is the way to go if you dont feel like upgrading but if you want the upgrade all the info is in my sig.

    Devhook:http://dl.qj.net/Devhook-0.51-3.01-FW-support-PSP/pg/12/fid/11596/catid/114
     
    Last edited: Jan 21, 2007
  3. alexsc

    alexsc Member

    Joined:
    Nov 6, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    Thanks very much for that info on devhook, i'll search for it. As for 3.03, is that the newest firmware? I thought you couldn't load isos off that version? And what is OE-B? (sorry i've been out of the psp scene since 2.6 fw ) ^_^; thanks alot.
     
  4. rsrepp

    rsrepp Regular member

    Joined:
    Sep 3, 2006
    Messages:
    396
    Likes Received:
    0
    Trophy Points:
    26
    The newest firmware is a custom firmware developed by Dark Alex. It is called 3.03OE-B as I have stated above. It can play iso's from the memstick along with psx games and homebrews. If I was you, I would look into upgrading to 3.03OE-B.
     
  5. alexsc

    alexsc Member

    Joined:
    Nov 6, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    Ohh, ok I get it. Sounds great, but is that version downgradeable? Im gonna upgrade anyway, just nice to know. Thanks again for your help.
     
  6. BurnCK

    BurnCK Regular member

    Joined:
    Mar 23, 2006
    Messages:
    588
    Likes Received:
    0
    Trophy Points:
    26
    Upgrade your 1.5 to 3.03OE (dont get confused with the original 3.03 fw). You can always go back to 1.5 if you change your mind (not that you would).....
     
  7. alexsc

    alexsc Member

    Joined:
    Nov 6, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    Okay, I got the OE-A version, do I want that one, or version B? And how exactly does this firmware execute isos? Is it from the system menu or what? Sorry for the noobish questions.
     
  8. BurnCK

    BurnCK Regular member

    Joined:
    Mar 23, 2006
    Messages:
    588
    Likes Received:
    0
    Trophy Points:
    26
    You need to upgrade to OE-A before you can do OE-B.
    ISOs load from the Game Menu.... :)
     

Share This Page