1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sony DSC-W5 Lens Problem

Discussion in 'Digital photography' started by Domreis, Jan 20, 2007.

  1. Domreis

    Domreis Regular member

    Joined:
    May 16, 2005
    Messages:
    3,090
    Likes Received:
    0
    Trophy Points:
    46
    Hello,

    I have Had my THIRD Sony DSC-W5 now for a year! When I first got it I opened the box and the lens wouldn't open, and the camera said "Turn off the back on" and beeped at me, so I took it back to the store and got an exchange! When I got home I cracked open the box, and the same thing happed! So I took it back to the store and said I would like to return this camera because it has done this twice and they said no, sorry we can only exchange it! So I said fine, I got the new camera and it worked fine until a week ago!

    I am having the same problem; I bought a accidental damage service plan for it so I took it into the store and sent it out for repair. I have the MPK-WA underwater housing for it that I bought a year ago that I am planning on take with me so I can take pictures while I am scuba diving in the Caribbean, but I leave in 4 weeks, and I wont get my camera back by then, I am trying to decide if I should buy a refurb for $180? But since this has happened 3 times I am sorta lenient! Should I buy a new camera, and a new underwater case or the refurb?

    Has anyone else had this problem with your W5 or W7?

    Thanks
    Domreis
     

Share This Page