1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

sound problem avi->mpg encoding with TMPGenc

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by bsauvage, Sep 5, 2002.

  1. bsauvage

    bsauvage Member

    Joined:
    Sep 5, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Hi.

    I've used tmpgenc to encode an avi (divx) to mpg in VCD format.
    Using high settings, picture is amazingly sharp, and sound is very good in the mpg as well.
    Problem starts once I burn the VCD with Nero. it says the file is not VCD compliant. I bypass the warning, then it burns all right but the resulting VCD has completely fcuked up sound!

    How can I fix that?

    Cheerc,

    Benny
     
  2. bsauvage

    bsauvage Member

    Joined:
    Sep 5, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    please HELP.... I haven't seen any solution to this problem before. Weird that Nero doesn't recognises the format...

     
  3. dRD

    dRD I hate titles Staff Member

    Joined:
    Jun 10, 1999
    Messages:
    8,650
    Likes Received:
    118
    Trophy Points:
    143
    Have you followed our guide and/or used TMPGEnc's VideoCD template for your settings?
     
  4. bsauvage

    bsauvage Member

    Joined:
    Sep 5, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    yes, the only step I haven't followed is to encode using a separate wav file for the sound together with the avi for the video.
    I'll try that.
    In any case, what I don't understand is why the resulting mpg is perfect, but not recognised as VCD format. That's really what bothers me.
     
  5. dRD

    dRD I hate titles Staff Member

    Joined:
    Jun 10, 1999
    Messages:
    8,650
    Likes Received:
    118
    Trophy Points:
    143
    Audio might be the issue, if it is in some non-compliant format in the original AVI, try the separate WAV trick and tell us if that helped.
     
  6. bsauvage

    bsauvage Member

    Joined:
    Sep 5, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    It didn't work. Nero still doesn't recognize it as a compliant VCD format.

    I'm using a template for high quality encoding, which should work: when I play it back on my PC it works perfect.

    Here are my template settings:

    object TMPEGConfigFile
    MPEG.Text = 'VideoCD HQ PAL'
    MPEG.Description = ''
    MPEG.OutputStreamType = MPEG_OutputStreamType_System_VideoAudio
    MPEG.OutputStreamType_ReadOnly = False
    MPEG.Video.StreamType = MPEGVideoEncoder_StreamType_MPEG1
    MPEG.Video.StreamType_ReadOnly = False
    MPEG.Video.Width = 352
    MPEG.Video.Width_ReadOnly = False
    MPEG.Video.Height = 288
    MPEG.Video.Height_ReadOnly = False
    MPEG.Video.YUVFormat = 1
    MPEG.Video.YUVFormat_ReadOnly = False
    MPEG.Video.DC_prec = 0
    MPEG.Video.DC_prec_ReadOnly = False
    MPEG.Video.VideoEncodeMode = MPEGVideoEncoder_VideoEncodeMode_Progressive
    MPEG.Video.VideoEncodeMode_ReadOnly = False
    MPEG.Video.VideoEncodeMode_CantSelExtType = False
    MPEG.Video.FrameRate = 3
    MPEG.Video.FrameRate_ReadOnly = False
    MPEG.Video.AspectRatio = 8
    MPEG.Video.AspectRatio_ReadOnly = False
    MPEG.Video.RateControlMode = MPEGVideoEncoder_RateControlMode_CBR
    MPEG.Video.RateControlMode_ReadOnly = False
    MPEG.Video.MaxBitRate = 0
    MPEG.Video.MaxBitRate_ReadOnly = False
    MPEG.Video.CBR_BitRate = 1150000
    MPEG.Video.MVBR_MaxBitRate = 3000000
    MPEG.Video.MVBR_MinBitRate = 0
    MPEG.Video.MVBR_Quality_P = 0
    MPEG.Video.MVBR_Quality_B = 20
    MPEG.Video.MVBR_EnablePadding = False
    MPEG.Video.VBR_AvgBitRate = 1150000
    MPEG.Video.VBR_MaxBitRate = 3000000
    MPEG.Video.VBR_MinBitRate = 300000
    MPEG.Video.VBR_EnablePadding = False
    MPEG.Video.AVBR_Quality = 50
    MPEG.Video.AVBR_MaxBitRate = 3000000
    MPEG.Video.AVBR_MinBitRate = 0
    MPEG.Video.AVBR_EnablePadding = False
    MPEG.Video.CQ_Quality = 50
    MPEG.Video.CQ_Quality_P = 0
    MPEG.Video.CQ_Quality_B = 20
    MPEG.Video.CQ_MaxBitRate = 3000000
    MPEG.Video.CQ_MinBitRate = 0
    MPEG.Video.CQ_EnablePadding = False
    MPEG.Video.VBVBufferSize = 0
    MPEG.Video.VBVBufferSize_ReadOnly = False
    MPEG.Video.GOP_SeqHeaderInterval = 0
    MPEG.Video.GOP_SeqHeaderInterval_ReadOnly = False
    MPEG.Video.GOP_I_FrameCount = 1
    MPEG.Video.GOP_I_FrameCount_ReadOnly = False
    MPEG.Video.GOP_P_FrameCount = 4
    MPEG.Video.GOP_P_FrameCount_ReadOnly = False
    MPEG.Video.GOP_B_FrameCount = 2
    MPEG.Video.GOP_B_FrameCount_ReadOnly = False
    MPEG.Video.GOP_BitStreamForEdit = False
    MPEG.Video.GOP_BitStreamForEdit_ReadOnly = False
    MPEG.Video.QuantizeMatrix_Intra_ReadOnly = False
    MPEG.Video.QuantizeMatrix_NonIntra_ReadOnly = False
    MPEG.Video.Profile = 4
    MPEG.Video.Profile_ReadOnly = False
    MPEG.Video.Level = 8
    MPEG.Video.Level_ReadOnly = False
    MPEG.Video.VideoFormat = 2
    MPEG.Video.VideoFormat_ReadOnly = False
    MPEG.Video.DisplayWidth = 0
    MPEG.Video.DisplayWidth_ReadOnly = False
    MPEG.Video.DisplayHeight = 0
    MPEG.Video.DisplayHeight_ReadOnly = False
    MPEG.Video.MotionSearchSpeed = MPEGVideoEncoder_MotionSearchSpeed_Slow
    MPEG.Video.MotionSearch_AlwaysHalfPel = False
    MPEG.Video.UseFloatDCT = True
    MPEG.Video.QuantizeMode = True
    MPEG.Video.QuantizeModeVal_Intra = 35
    MPEG.Video.QuantizeModeVal_NonIntra = 35
    MPEG.Video.YUVBasicYCbCr = False
    MPEG.Video.QuantizeMatrix_Intra = {
    081013161A1B1D22101016181B1D222513161A1B1D22222616161A1B1D222528
    161A1B1D202328301A1B1D202328303A1A1B1D22262E38451B1D23262E384553}
    MPEG.Video.QuantizeMatrix_NonIntra = {
    1011121314151617111213141516171812131415161718191314151617181A1B
    14151617191A1B1C151617181A1B1C1E1617181A1B1C1E1F1718191B1C1E1F21}
    MPEG.Audio.StreamType = MPEGAudioEncoder_StreamType_MPEG1_Layer2
    MPEG.Audio.StreamType_ReadOnly = False
    MPEG.Audio.SamplingFrequency = 44100
    MPEG.Audio.SamplingFrequency_ReadOnly = False
    MPEG.Audio.ChannelMode = 0
    MPEG.Audio.ChannelMode_ReadOnly = False
    MPEG.Audio.CantUseMono = False
    MPEG.Audio.BitRate = 224000
    MPEG.Audio.BitRate_ReadOnly = False
    MPEG.Audio.CalcCRC = True
    MPEG.Audio.CalcCRC_ReadOnly = False
    MPEG.Audio_OriginalFlag = False
    MPEG.Audio_OriginalFlag_ReadOnly = False
    MPEG.Audio.CopyrightFlag = False
    MPEG.Audio.CopyrightFlag_ReadOnly = False
    MPEG.Audio.PrivateFlag = False
    MPEG.Audio.PrivateFlag_ReadOnly = False
    MPEG.Audio.EmphasisType = 0
    MPEG.Audio.EmphasisType_ReadOnly = False
    MPEG.System.StreamType = MPEGSystemEncoder_StreamType_MPEG1
    MPEG.System.StreamType_ReadOnly = False

    All the standard specs I can think of (bitrate, format,..etc.) seem ok. Ony ones I can think of: the sound 'error check' (CalcCRC) which is checked, and in the video settings the 'field order' which is set to "Bottom Field First (Field B)"

    HELP.................!

    Benny
     

Share This Page