1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

sound sync

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by rodleye, Dec 11, 2002.

  1. rodleye

    rodleye Member

    Joined:
    Dec 11, 2002
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    my problem is / sound is sometimes ahead of
    the video by some 5 or 10 seconds, has anyone got any clues as to what is going wrong, i am using virtual dub then tmpgenc
    please help
     
  2. Dela

    Dela Administrator Staff Member

    Joined:
    Aug 25, 2002
    Messages:
    8,949
    Likes Received:
    1
    Trophy Points:
    118
    Did u try extractin the audio with virtualdub and converting it to standard then doin the video with tmpgenc and multiplexing em?
     
  3. A_Klingon

    A_Klingon Moderator Staff Member

    Joined:
    Dec 29, 2001
    Messages:
    529
    Likes Received:
    0
    Trophy Points:
    26
    rodleye: Using TMPGEnc, go to Settings --> Advanced --> Source Range. At the bottom you will see a little window called "Audio gap correct". With it you can change the audio offset value to make your a/v sync match up *perfectly* when you play the disc back on your standalone.

    But it requires a lot of experimentation, and a lot of test-encodes of short clips to get it "just right". A plus (+) value will put your audio further *ahead*, while a minus (-) value will delay the audio. It takes a lot of trial-and-error to get it just right.

    -- Mike --
     
  4. rodleye

    rodleye Member

    Joined:
    Dec 11, 2002
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    dela
    what do u mean by converting audio to standard ??
     
  5. rodleye

    rodleye Member

    Joined:
    Dec 11, 2002
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    cheers mike i'll try that
     
  6. Dela

    Dela Administrator Staff Member

    Joined:
    Aug 25, 2002
    Messages:
    8,949
    Likes Received:
    1
    Trophy Points:
    118
    I meant the standard settings for your vcd!
     
  7. rodleye

    rodleye Member

    Joined:
    Dec 11, 2002
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    mike is it possible to check this procedure befofe u write the disk, i have tried to adjust it by minus 7 7 seconds but it doesn;t apear to change anything
     
  8. A_Klingon

    A_Klingon Moderator Staff Member

    Joined:
    Dec 29, 2001
    Messages:
    529
    Likes Received:
    0
    Trophy Points:
    26
    rodleye:

    Using "Source-Range" (where you find the audio delay box anyway), only specify a *short* piece of your video file to encode. There are 2 boxes - 1 for start position, and 1 right underneath it for the end position. (You can use the slider bar). The audio offset positions are measured in ms (milliseconds).

    7 seconds is an *awfully* big mismatch though (7000 ms!) You can try different settings for each short test encode and adjust up or down as necessary.

    It's better to burn your short test clip as a vcd, and then play it back on your standalone, but you *can* just play your clip with Windows Media Player (in a pinch). But I have found that the Media Player (or a software player like windvd or whatever) gives an erroneous effect with the audio. The a/v sync may be *perfect* when played back from a vcd on your standalone, by still be off when played back on your computer.

    Also, the numbers you choose (either + or -) aren't necessarily accurate. For example, when I rip some of the Star Trek Next Generation tv episodes, Smartripper reports them as having an audio/video offset of +27 ms. (Which, you would think, could be perfectly offset by choosing *minus* 27 ms in TMP.) However, I found that choosing PLUS +150 ms, gave ultra-perfect a/v sync when playing back the burned vcd.

    You'll just have to experiment a bit (or a lot). Encode a short piece near the beginning of your video file. When you find the best possible value (by carefully watching an actor while he is speaking, for example), the _whole_ file should maintain perfect sync throughout. No two dvds will use exactly the same a/v delay settings.

    I have found that it is unnecessary to change the exact values, so I add or decrease the amount by 25 ms either way. If using 100 ms produces late audio (audio behind the video), I increase to 125 ms and try again.

    Troublesome, yes, but you learn to get pretty good at it after a while. All my vcds have ultra-perfect sync throughout.

    -- Mike --
     
  9. Synapsi

    Synapsi Member

    Joined:
    Dec 10, 2002
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    11
    I've got same problem, but when I try to convert a slice of movie using 1 or 2 vob files different from 1st. (vob number 3 and 4, for examples)
    Is that the same thing or just some "human" mistake?
     
  10. rodleye

    rodleye Member

    Joined:
    Dec 11, 2002
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    trying that now mike, i actually meant 7 seconds
    audio ahead of video as counted in my head, it takes some figuring out thanks for your time and patience anyway cheers
     
  11. A_Klingon

    A_Klingon Moderator Staff Member

    Joined:
    Dec 29, 2001
    Messages:
    529
    Likes Received:
    0
    Trophy Points:
    26
    Synapsi - no, it doesn't matter which individual .vob, or set of .vobs the video originates from, or whether they are sequentially numbered or not. For example, some individual Star Trek episodes, when ripped with Smartripper, start out as VTS_01_1.VOB, but then jump right to VTS_01_3.VOB, VTS_01_4.VOB etc. (omitting VTS_01_2.VOB). This is perfectly normal for that particular episode. If you look closely, the first vob in your series might be 0 bytes.

    (Long story short): Doesn't matter how SmartRipper, or another ripper names your vobs - they can all be adjusted, audio/video wise, with TMP.

    -- Mike --
     

Share This Page