1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stretched video on tv

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by Squeeto, Jul 27, 2003.

  1. Squeeto

    Squeeto Member

    Joined:
    Jul 27, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    I know this has been asked a few times but I have a bit of a twist to the problem. I have spent hours converting my camcorders avi files to mpeg2 for SVCD.

    SuperVideoCD NTSC Mpeg-2 480x480 29.97fps CBR 2520kbps

    The original avis, being so large, are now gone. The mpgs play just fine in Media Player but play width stretched on tv.
    I have tried every option in tmpgenc-
    Fit to Frame (Preserve aspect ratio)
    Fit to Frame
    1:1
    4:3
    16:9
    Always plays the same! These are important first months of my childs life clips. Any help is appreciated.
    Thank you
     
  2. Squeeto

    Squeeto Member

    Joined:
    Jul 27, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    A little more info... I created a test avi and found:
    tmpgenc at 16:9, MPlayer good, tv width stretched
    tmpgenc at 4:3, MPlayer height stretched, tv good

    Ok the fix is use 4:3 when creating the mpeg from avi but I still need to know how to fix my existing mpegs.

    Also, why can't it look good in both Media Player and on t.v.? These vids are for the future; which way should I go? 20 years later I am sure that I will need to extract the info and cut it to some new medium.
     
    Last edited: Jul 27, 2003
  3. Dela

    Dela Administrator Staff Member

    Joined:
    Aug 25, 2002
    Messages:
    8,949
    Likes Received:
    1
    Trophy Points:
    118
    There is not much you can do about this because it is the fault of your dvd player and not your encoding!
     
  4. Squeeto

    Squeeto Member

    Joined:
    Jul 27, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    >>There is not much you can do about this..

    You are right about that with tmpgenc (ver 12a). It seems to assume that it knows best when you select the SVCD(NTSC).mcf; all efforts to change aspect ratio seem to fail under 'Source aspect ratio'. BUT, after a lot of tries I found out how.

    Under 'Image positioning method' choose 'Center (custom size)' and set the pixels to '480 x 654'. This restored the image back to original for my tv. I tried it on a friend's high definition tv with his Apex unit (I have a Lenoxx) and got the same good results.

    Of course the video still plays squeezed for Media Player but I now believe that it lacks the appropriate codec for SVCD type mpegs. This is how I got into trouble in the first place - not knowing the output of my video camera I selected the aspect ratio that made it look good on my computer.

    I found a player that actually displays the aspect ratios correctly called VLC by VideoLan. More confirmation that I am on the right track and MPlayer can be avoided.

    >>These vids are for the future; which way should I go?
    To answer my own question, I have decided for cost and permanency to use the SVCD format, so use it, aspect ratio and all. If MicroSoft wants to get on board, it is their decision.

    Squeeto
     
  5. Dela

    Dela Administrator Staff Member

    Joined:
    Aug 25, 2002
    Messages:
    8,949
    Likes Received:
    1
    Trophy Points:
    118
    Well i would actually suggest you try DVD2SVCD with CCE SP if possible :)
     
  6. mertens

    mertens Member

    Joined:
    Aug 1, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    When I convert from .avi to mpg2 with TMPGEnc, the picture looks vertically stretched. How do I keep the video ratio the same during the conversion? I have been choosing SVCD NTCS as the outgoing file. Here is the properties of the origonal avi file:

    video: 320 x 192, 24 Bits, 770 Frames, 30.001 Frames/Sec, 433 KB/Sec, Indeo® Video 5

    I have tried playing it in the Windows Media Player and other VCD players, and the picture looks the same. I have tried setting the aspect ratio at 1:1 and 4:3. Both ended up looking the same. I am looking around vcdhelp.com, but I can't find the page I need or if it is even here.

    I think it has changed the ratio from 320:192 to 480:480. The picture doesn't look like a square, it is still stretched out widescreen, but it looks stretched taller. I think what TMPGEnc is doing is trying to keep the ratio the same by putting black bars on the top and bottom of the "square" picture so that the movie playing looks like widescreen, but it isn't enough. I don't know how to fix it or if it can be done.
     
  7. Squeeto

    Squeeto Member

    Joined:
    Jul 27, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    Mertens-
    I think when you choose SVCD format in Tmpgenc you always get 480x480, it is a property of the SVCD format. As I had said above, Tmpgenc seems to think it knows best but there is a way around it.
    I don't know which version of Tmpgenc you have (probably the latest) but I have the last free version and so the nomenclature will be different.
    Look for something like 'Video arrange method', my old version says 'Image positioning method' and choose the option which allows you to change the 480x480 entry. This worked for me. I am sorry but you will probably get black bars.
    If you want to see the proper aspect ratio for your video in the SVCD format (ie, how it would show on your tv) try VLC by VideoLan. Media Player doesn't do this well (maybe later the proper codec will be installed).
    If you only want to watch on your vids on your computer monitor for Media Player remember that if you ever cut them to disk they will play squished on your tv.
    Squeeto
     
  8. mertens

    mertens Member

    Joined:
    Aug 1, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Thanx for your help Squeeto. The picture looks better but it is still a little stretched vertically. Here is what I have done: First I pick SVCD NTSC Film and then find my file. I left the source aspect ration at 1:1 VGA, but I am thinking of putting it at 16:9 NTC since that is the ration closest to the original. Then I do the trick you told me and change the final ratio to match the original and convert it.

    Is there anything else I can do to fix the ratio or is this as far as the converter can take me? It doesn't really bother me that much, but it still kinda does.
     
  9. Squeeto

    Squeeto Member

    Joined:
    Jul 27, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    Mertens-
    You should be able to totally fix the aspect ratio with the custom settings. I kept on increasing the second parameter until it looked exact. You may have to increase the first or try decreasing one of them instead.

    I would suggest closing the wizard if you are running it and do it manually. Load SuperVideoCD(NTSCFilm).mcf and hit 'Setting' (the older free tmpgenc calls this 'Configure'). You can set the aspect ratio under the Advanced tab.

    You could also try 'Loading' other .mcf templates. These might work better for you.

    S.
     
  10. mertens

    mertens Member

    Joined:
    Aug 1, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Thanx for your help Squeeto. I finally got the program to convert it at the right aspect ratio.
    There is a way to change the final size from 480:480. I right clicked on the word size and unlocked the option and was able to type in anything I wanted. It looks great on my computer, but it is still a little stretched vertically on the TV. It doesn't really matter. I'm actually using my Dreamcast to compare because my DVD player won't read VCD disks. The picture will probably look better once I get a DVD player that is compatible and maybe a widescreen TV. My current entertainment system is due for an overhaul.

    Anyway, thanx for your help.
     

Share This Page