1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Subtitle playback on ripped movies

Discussion in 'DVDR' started by surferboy, Oct 15, 2003.

  1. surferboy

    surferboy Member

    Joined:
    Oct 11, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    I've been ripping DVD-9 movies (using Decrypter) and splitting to 2 DVD-R's (using Info Edit). However, upon playback, either one or both discs may show subtitles as if they were already selected to be on. I know I could strip the streams and remove the subtitles all together, but I want to keep them. I just need to know if there is a method that can be performed to prevent them from displaying unless I decide to select it from the main menu as it should be.
     
  2. baggins1

    baggins1 Member

    Joined:
    Sep 5, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    16
    Get dvd shrink and put movie on to one disc and see if you can get subs on as well
     
  3. nuklehead

    nuklehead Member

    Joined:
    Sep 25, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    16
    It may just be your dvd player, mine often does the same thing, not just with dvd copies, but with originals too. Not a big deal, you just turn them off.
     
  4. baggins1

    baggins1 Member

    Joined:
    Sep 5, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    16
    Still don't see why you would want to put it on to two dvd's when you can use one. I may be old but my eyesight is good and the quality is still very high
     
  5. Oriphus

    Oriphus Senior member

    Joined:
    May 31, 2003
    Messages:
    6,011
    Likes Received:
    0
    Trophy Points:
    116
    Very simple. Your DVD player is set to play subtitles on start-up. This can be changed using the DVD players menu.
     
  6. surferboy

    surferboy Member

    Joined:
    Oct 11, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    Thanks for the replies... would like to address a few; First, I only use compression programs such as DVD Shrink or Xcopy express if the ratio is 90% or better, otherwise you defeat the purpose of going to a higher standard if you are trying to get away from video degradations like vcd and svcd.

    Next, I have 3 stand alone players as well as drives on 2 desktop systems, and they all behave the same way (even PowerDVD), so it appears that it was embedded in the navigation packs from the IFO files during editing...

    As I stated initially, I can go on adjusting the settings and turn them off whenever I see them appear, but I was hoping someone would offer a technical way to edit the subtitles and how they react. Is it possible??

    P.S. Gave it some thought, and double checked the DVD settings on my standalone players... They were set to 'off', so that probable cause can be ruled out.
     
    Last edited: Oct 15, 2003
  7. Oriphus

    Oriphus Senior member

    Joined:
    May 31, 2003
    Messages:
    6,011
    Likes Received:
    0
    Trophy Points:
    116
    In DVD Shrinks menu, select show all substreams and not just once less than 1MB. Delete them all. I know you said you wanted them, but its the easiest thing to do. You could attempt to find the problem by editing the IFO file in IFOEdit or something, not my cup-of-tea though ;-)
     

Share This Page