1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Subtitle Troubles

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by Midus, May 8, 2004.

  1. Midus

    Midus Member

    Joined:
    May 8, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    11
    I'm new to encoding .Avi files to Mpeg so I decided to follow the guide thats here. I sucessfully encoded several of my files to Mpeg ,but when I watched them in full screen mode, the subtitles got cut off a bit. I thought it was my screen at first so I re-adjusted the vertical but nothing happened. I decided that it was just my computer and burned them to VCD. I then played them on my DVD player and the subtitles were still too low. I followed everything in the guide and don't know what to about my subtitles.

    Note: The subtitles are on the video, so I guess I should say that the video is too low, not the subtitles.
     
  2. Midus

    Midus Member

    Joined:
    May 8, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    11
    I found the answer, but I still have a problem. Someone had the same problem and was told to go to center(custom size) and to calculate...but I don't know what that means
     
  3. shiroh

    shiroh Guest

    ha, i think thats me.

    making vcd ? that will be 352x240 pixels for the video size. try go to video arrange method and put the size to 336x224. you can go look at the preview under "file" drop down menu. there you'll see that there is a black bar surrounding the picture. that is what we want. i've check from a video source of 640x480 and it doesn't look stretch. i'm saying this cause mathematically it is stretch, a little bit.

    i don't usually do vcd so i'm not 100% percent sure if the subs will still be missing or not.

    here is a little tip on how to calculate my way.choose the widt size you want in the video arrange mathod.(i would choose something divisible by 16) divide it with the width size. and then times it with the video height.

    example,
    i chose the arrange method as 336(lets give it variable A) for the 352x240 video(and this the variable B and C)(on the video tab in settings)
    and give the heigh you want as D

    (A/B)xC=D

    (that means 336/352)x240= 229.0909
    for me i prefer something divisible with 16 so i chose 224, the nearest roundup.

    my method could be wrong as i figured it out on my own after many thoughts and tips.

    try making svcd if the quality of vcd is unbearable :p

    if you got the .avi file and the subtitle file seperately, the you don't need to do this. you can adjust how the subs go.



    xsvcd for me. it means my set up is
    720x480 mpeg-2
    motion search = highest quality
    DC = 10bit
    2-pass vbr min bitrate=950kbps max bitrate=6400kbps average bitrate=3650kbps (depending on the source quality and my needs)(fits about 30 minutes of video)
    video arrange method=640x432 (if it got subs like the one discussed)
    b picture = 2 or 3
    force picture setting if i got the time
    custom quantize matrix, i tried Didee's HVS and will try Bach1's.

    audio mpeg1 layer II (using other application, which is DarkAvenger's headAC3he)
    freq = same as source
    joint stereo or dual channel(depend on source)
    224kbps cbr

    *note this, not all player can play this.
    *how to burn ? fire up nero(not express) choose svcd and uncheck "make compliance svcd" drag and drop and burn.


    oh and inverse telecine when possible and i'm feeling like doing it.(this is a subject you need to search yourself)(try doom9 forum in the dvd2avi section)

    cheers




     
    Last edited by a moderator: May 8, 2004
  4. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    If you post the Original resolution of your Source File then I can tell you how to use the "Center (Custom size)" setting to display your Movie in the correct aspect ratio without the Subtitles being too low...Cheers
     

Share This Page