1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Subtitles are gone in Kill Bill

Discussion in 'DVDR' started by B_Dogg990, Jan 23, 2005.

  1. B_Dogg990

    B_Dogg990 Member

    Joined:
    Jan 22, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    I used DVD shrink, the movie plays ok, but the subtitles are gone (the ones that are supposed to be in the movie when they are speaking Japanese). Anyone know how this happened?
     
  2. B_Dogg990

    B_Dogg990 Member

    Joined:
    Jan 22, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    anybody?
     
  3. flip218

    flip218 Moderator Staff Member

    Joined:
    Apr 25, 2004
    Messages:
    8,344
    Likes Received:
    0
    Trophy Points:
    116
    did you leave the box for english subtitles checked?
     
  4. B_Dogg990

    B_Dogg990 Member

    Joined:
    Jan 22, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    Yes, the box for english subtitles is checked
     
  5. flip218

    flip218 Moderator Staff Member

    Joined:
    Apr 25, 2004
    Messages:
    8,344
    Likes Received:
    0
    Trophy Points:
    116
    are you watching on a standalone or your pc?
     
  6. brobear

    brobear Guest

    I recorded Kill Bill. The subtitles for translation are part of the movie track and not listed as the subtitles that can be turned off and on. If missing, I'd say there was a fault made in copying and it'll have to be redone. If editing, be careful what you edit out.
     
  7. B_Dogg990

    B_Dogg990 Member

    Joined:
    Jan 22, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    I've been watching it on my ps2. I didn't put the menu or any extra options in, just the main movie.
     
  8. brobear

    brobear Guest

    Did you try it on a standalone player? Does the PS2 normally show subtitles with movies?

    I never use PS2 myself for playing movies. Players are so cheap now, it's a waste of more expensive equipment to play movies on the PS2, even if it will. Works if that's all available I guess.
     
  9. StanH1000

    StanH1000 Regular member

    Joined:
    May 19, 2004
    Messages:
    718
    Likes Received:
    0
    Trophy Points:
    26
    For KillBill there are two choices for English subtitles. The larger will provide subtitles through the entire movie, whereas the smaller only has the subtitles for the non english dialouge. When using DVD Shrink, you must include the smaller english subtitle track in the burn and you must the "enable subtitles" on your DVD player. Since the only subtitle tract burned was the "as needed" english subtitle tract, it will then come on during the appropriate scenes in the movie. This has worked for both KillBill 1 and KillBill 2, just remember to enable the subtitles during playback.
     
  10. bbmayo

    bbmayo Active member

    Joined:
    Oct 31, 2004
    Messages:
    5,088
    Likes Received:
    0
    Trophy Points:
    96
    StanH1000,
    I would say you are wrong on this one. I took out all subtitles in fact I have Shrink set up in preferences to only allow Forced subtitles which is what these are in Kill Bill. I would tend to agree with Brobear there must have been something missed when ripping the DVD as these subtitles are part of the movie. Mine play fine and none of the subtitles where or are ever checked on my Shrink. To be sure though i would go to the prefrences in Shrink and check the little bix under "Stream Selections" near the bottom that says "disable all subpictures except menus and forced streams" then you should never have this problem again. :)
     
  11. brobear

    brobear Guest

    B_Dogg990
    bbmayo's suggestion will work if you never want to see any subtitles, except those that are a part of the movie. The forced subtitles were the ones you wanted to see anyway. As we told you, forced subtitles are a part of the movie.
     
  12. StanH1000

    StanH1000 Regular member

    Joined:
    May 19, 2004
    Messages:
    718
    Likes Received:
    0
    Trophy Points:
    26
    The subtitles are not embedded in the KillBill movies. You have to include the smaller of the two English subtitle tracts and the Main movie after a shrink analysis. If the choices do not appear, go to Edit/preferences/stream selections/and do Not check the box for "disable all subpictures except menus and forced streams". Then analyze, choose the main movie title and only the smaller of the two english subtitle tracts, burn, and enable subtitles (there should only be one choice) from your player or remote. I have done this successfully for both KillBill 1 and 2. When burning the main movie only, I too got no subtitles when needed during the film.
     
  13. slamdvanz

    slamdvanz Member

    Joined:
    Jan 23, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    Thats all I needed to on my dvd player (toshiba sd-1800) was to turn on subtitles because for some reason they were off and it worked fine. Just look on your remote for the button.
     
    Last edited: Jan 26, 2005
  14. flip218

    flip218 Moderator Staff Member

    Joined:
    Apr 25, 2004
    Messages:
    8,344
    Likes Received:
    0
    Trophy Points:
    116
    slamdvanz,

    Nice sig? hint ... hint.
     
    Last edited: Jan 26, 2005
  15. slamdvanz

    slamdvanz Member

    Joined:
    Jan 23, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    Sorry my bad...should be fixed now ;]
     
    Last edited: Jan 26, 2005
  16. slamdvanz

    slamdvanz Member

    Joined:
    Jan 23, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    ugh....now it should be gone. For some reason it didnt erase...sorry guys.
     
    Last edited: Jan 25, 2005
  17. brobear

    brobear Guest

    slamdvanz
    You're lucky, I've seen people disappear over those spam ads.
     
  18. brobear

    brobear Guest

    On the matter of subtitles; if one is worried about them, then leave them all in. They take up such a small amount of space, their effect on compression is minute. Then it's a simple matter to control them from the menu as mentioned.
     

Share This Page