1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

swap magic 3.6 works on all PS2??

Discussion in 'PS2' started by Spyker90, Jan 10, 2008.

  1. Spyker90

    Spyker90 Member

    Joined:
    Jan 10, 2008
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    11
    i have US scph 70001 black slim ps2, will swap magic 3.6 work on my ps2? i think its swap magic 3.6 plus or does it matter?
     
  2. mack202

    mack202 Member

    Joined:
    Jan 3, 2008
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    16
    Yes they will work. Version 3.6 works all versions including 50001/50010 and NEW slim PSTWO, use it with swap tool pro, or a fliptop, fliptop voids warranty. But you are better off to get the swap magic pro 3.8 coder.
     

Share This Page