1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sweet PSP!!! Downgrade/Upgrade Possible?

Discussion in 'Sony PSP - Mod and firmware discussion' started by Dante05, May 10, 2007.

  1. Dante05

    Dante05 Guest

    Hey I just got a brand new PSP. According to this site forums.qj.net/f-guides-general-psp-42/t-determining-psp-firmware-using-box-codes-mar-29-2007-28718.html

    My PSP box has the letter "L". So is it a 2.80 or 2.81 or the same thing? Also, how do I downgrade? I heard that 3.03 oe-c it was the version with the least issues right? Am I suppose to downgrade first and then upgrade to 3.03 oe-c? If so, how? Sorry for all the questions. I'm just really excited and want to get started on my brand new PSP!!! Thanks!!!
     
  2. glenquag

    glenquag Regular member

    Joined:
    Mar 7, 2007
    Messages:
    1,879
    Likes Received:
    0
    Trophy Points:
    46
    Yes, you must downgrade and then upgrade to 3.03oe-c or any other custom firmware, I like 3.40oe-a though. Well your on 2.81 so you have to update to 3.03, then downgrade to 1.5 then upgrade to OE. You need GTA Liberty City Stories though, an unpatched one. You can tell if it's unpatched by if it has a 2.00 update with it on the disc or not.

    UPDATE: Here's a guide: http://forums.qj.net/f-psp-hacks-9/t-guide-281-303-to-15-downgrade-guide-92517.html
     
    Last edited: May 10, 2007
  3. Dante05

    Dante05 Guest

    Thanks for the info!!!! Whats the difference between 3.03oe-c and 3.40oe-a?
     
  4. glenquag

    glenquag Regular member

    Joined:
    Mar 7, 2007
    Messages:
    1,879
    Likes Received:
    0
    Trophy Points:
    46
    3.40oe-a supports wider selection of playable PSX games, and high resolution video. Plus, higher firmware lol.
     
  5. Dante05

    Dante05 Guest

    so once it is downgraded to 1.5, then I upgrade to 3.40oe-a? Just making sure. Thanks again!!!
     
  6. glenquag

    glenquag Regular member

    Joined:
    Mar 7, 2007
    Messages:
    1,879
    Likes Received:
    0
    Trophy Points:
    46
    Yep! Just download the 3.40oe-a update or use the easy installer. Your welcome lol.
     
  7. silentdan

    silentdan Member

    Joined:
    May 5, 2007
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    16
    But most important thing of all that you need is GTA LCS unpatched game.Without this game downgrading is not possible so u need to get your hands on this first before you proceed with anything else.
    Try to rent it from your local Blockbuster and if they dont have it than ebay is your best bet.I got mine from ebay and it cost me $50 Canadian and i can honestly say money well spent cause i had a psp with 2.81 firmware and downgraded with the gta game and then installed 3.03 oe-c and im happy as a clam.
    Im my opinion you should go with 3.03 oe-c cause its the most stable version and it also plays psx games.
    Good Luck!
     
  8. Dante05

    Dante05 Guest

    Really? I guess thats alright. Hey I just bought this Memory stick 2 GB but on the back of the case it says that the requirements is a PSP system software version 2.60 or later. Well since I'm downgrading my PSP and upgrading it, will this stick work? I haven't opened the case yet just in case it doesn't work and I'll go refund? Anyone know anything about this? Thanks.
     
  9. glenquag

    glenquag Regular member

    Joined:
    Mar 7, 2007
    Messages:
    1,879
    Likes Received:
    0
    Trophy Points:
    46
    well do you have any other stick? You can use that once you are on 3.40oe-a but, i think you need a 1gig or lower while your on 1.5/downgrading. I don't know for sure, do some research
     
    Last edited: May 11, 2007

Share This Page