1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

sync issues after fixing ac3 audio with ac3fix

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by mub6, Dec 16, 2007.

  1. mub6

    mub6 Regular member

    Joined:
    Oct 2, 2005
    Messages:
    474
    Likes Received:
    0
    Trophy Points:
    26
    Hiya guys.
    i recieved an illegal ac3 format with my dvd authoring programme.
    so i ran the ac3 audio through ac3 fix, and the fixed audio now does author perfectly fine, but during playback it gives me sync issues.
    i checked the runtime of the fixed audio, and i found that there is a whole second shaved of it.

    so how can i fix this problem, i have ran ac3fix once before and it gave me no such problems,
    thanks in advance
    regards,
    Mubs
     
  2. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    Try this with the original file. Before you encode the file, run it through AviMux_Gui: http://www.alexander-noe.com/video/amg/ (vl 17.7-binary) Drag your original file into the top window, highlight it and select generate data. In the lower window, select audio and any delay will appear to the right in ms. If other than 0 appears, select start, place and name your new file as you wish and encode it. Only takes a minute or two but doesn't help on gradual sync issues. The original probably won't show any sync issues on your pc.
     
  3. mub6

    mub6 Regular member

    Joined:
    Oct 2, 2005
    Messages:
    474
    Likes Received:
    0
    Trophy Points:
    26
    the original .avi didnt have sync issues.
    i extracted the ac3 audio out of it, and fixed it because it wasnt recognised as a correct ac3 file by my dvd authoring software.
    i encoded the video as an elementary stream. and when i put it all together in my dvd authoring programme, it gave me sync issues, like i said,
    the fixed audio is one second shorter than the original audio.

    i have encoded and authored many many movies like this. and i have never ever recieved sync issues.
     
  4. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    I'm not sure I understand here, the original file may not show any sync issues. Don't extract anything and run the original file with no sync issues through AviMux_Gui and if you see any delay, save it and use that new avi. Actually, I check all my files first.
     
  5. mub6

    mub6 Regular member

    Joined:
    Oct 2, 2005
    Messages:
    474
    Likes Received:
    0
    Trophy Points:
    26
    ran it thru avimux gui.
    there is no delay,
    goes back to what i was saying... THERE IS NO SYNC ISSUES OR DELAY IN THE ORIGINAL AVI FILE :D
     
  6. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    The original file very rarely will show any sync issues until converted, I check all mine first. Saw this on another forum but haven't tried it myself. "Open the avi in virtualdubmod (click OK to the VBR warning you may get), then go Streams->Stream List. Right click on the audio and select Full Processing. Right-click again and select Compression. Choose Uncompressed PCM. Click OK, then click Save WAV and create new file. The file size should be around 100mb per 10 minutes of footage (i.e. 90 minute file should produce a 900mb file, give or take a few MB). Once this completes, click on Add, and select your wav file. Click on the MP3 audio track, then click on the disable button. Click OK, then go File->Save as. Make sure it is set to Direct Stream Copy, and save a new avi file with just your new audio track. Finally, open this new avi file, and test it for audio sync. If everything is good, use this. If not, do a scan for bad frames in virtualdubmod."
     
  7. MysticE

    MysticE Active member

    Joined:
    Nov 15, 2003
    Messages:
    2,787
    Likes Received:
    0
    Trophy Points:
    66
    Actually on the version I use, Virtualdubmod 1.6.0.0 surround, when the VBR warning appears I have to click NO, to not rewrite.

    Simply choosing Full Processing for the audio is all that is needed (no reason to right click and select PCM).

    Again not necessary.

    Try this. Open your AVI. Set Video to Direct Stream Copy. Set Audio to Full Processing (do nothing else) and click OK. Now go to File->Save as and save the new AVI. It will be much larger and if you reopen it, under Stream List you should now see only the PCM audio listed. Done.
     
  8. mub6

    mub6 Regular member

    Joined:
    Oct 2, 2005
    Messages:
    474
    Likes Received:
    0
    Trophy Points:
    26
    thats cool,
    thanks for that,
    just one issue,
    i started out with 5.1 channels, will the output audio still give me the same number of channels?
    and can i use this audio and encode it to ac3 for use with my dvd?
     

Share This Page