1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ta-082 emulation

Discussion in 'Sony PSP - Mod and firmware discussion' started by 9mmGreen, Jun 20, 2007.

  1. 9mmGreen

    9mmGreen Member

    Joined:
    Jun 20, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Hi all. New to the forums. I recently purchased a PSP, and I have a few question. My PSP is running V 3.11 of the Firmware. It auto updated when I swithched it on for the first. Gave me the option actually but refused to read discs till I upgraded. Anyway It has the TA - 082 mother board. From what I have read this means I can't run downgraded versions of the firmware, unless I want to brick my console. It is a european PSP in case that makes any difference.

    I am particulary interested in emulating my old PS1, SNES, and Megadrive games. Is this posibble at all. I.e is there any opende V. 3.11 versions of the firmware. If so where can I get them?
     
  2. XdogmaX

    XdogmaX Member

    Joined:
    Jun 19, 2007
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    11
    from all the post i've read u should try to trade it for a version 3.3 or lower..but im a newbie so i could be wrong
     
  3. okthen12

    okthen12 Guest

    awwww man you should not have upgraded, sorry but the only way you can get ps1 games on your psp is through the ps3 store.... Sony have made it impossible to read iso's and eboots, the only official sony version that supports it is 1.5 and lower. Im afraid to say that only 3.03 and lower is available for downgrade. But whatever you do, DO NOT upgrade in my opinion. Psp updates are mainly for security and nothing else. Hopefully there will be a 3.10 or higher downgrader soon. Good Luck if it comes.
     
  4. 9mmGreen

    9mmGreen Member

    Joined:
    Jun 20, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Does my inability to downgrade only effect my ability to emulate ps1 software. Can i still emulate the snes, megadrive etc,, with the right emulator?
     
  5. glenquag

    glenquag Regular member

    Joined:
    Mar 7, 2007
    Messages:
    1,879
    Likes Received:
    0
    Trophy Points:
    46
    Nope trade it on for a 3.03 or under. On anything thats 3.10 or above you cannot downgrade and use emulators/homebrew/iso's. So no, you can't emulate or play ps1 games on your psp unless you have a ps3 and buy them from the store. There isn't a very big selection though.
     
    Last edited: Jun 20, 2007
  6. 9mmGreen

    9mmGreen Member

    Joined:
    Jun 20, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    I take it I can't Mod it for GPS either then.
     

Share This Page