1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The time has come, plz Help a fellow out..

Discussion in 'Sony PSP - Mod and firmware discussion' started by solidusxx, Jun 1, 2007.

  1. solidusxx

    solidusxx Member

    Joined:
    Apr 6, 2007
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    16
    Finally nabbed a brand new 2.71 PSP so I need a LIL help to get started.

    1) Website to buy cheap 4 GIG mem cards, I prefer a place with real fast shipping if possible. Any reliable legit suggestions? And what type should I nab? Kingston? Sony?

    2)How to downgrade. Where are the DOWNGRADERS? The semi-newbs Guide to downgrading and upgrading your PSP.

    I would GREATLY appreciate any info, thanks fellas.
     
  2. schism123

    schism123 Member

    Joined:
    Nov 18, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    16
  3. mrmcman

    mrmcman Guest

  4. PeaInAPod

    PeaInAPod Active member

    Joined:
    Nov 28, 2005
    Messages:
    3,065
    Likes Received:
    0
    Trophy Points:
    66
    DO NOT UPGRADE TO 3.03

    Any PSP with firmware 2.71 with any motherboard can be downgraded and you won't need a unpatched version of Grand Theft Auto: Liberty City Stories. Post what motherboard you have. And I will post the corresponding guide. And again DO NOT UPGRADE TO 3.03 !
     
  5. mrmcman

    mrmcman Guest

    i was just saying that cuz it worked for me...but then, i do have gtalcs, and have had it since it came out:p
    i guess ur right peainapod, it is better to keep goin with 2.71, even if it is more complicated
     
  6. PeaInAPod

    PeaInAPod Active member

    Joined:
    Nov 28, 2005
    Messages:
    3,065
    Likes Received:
    0
    Trophy Points:
    66
    @mrmcman

    I dont mean trash your post, but for him upgrading to 3.03 would have been suicide.


    @solidusxx

    You have two options. One being posting your motherboard version and then I would post the appropriate guide OR two upgrade to 2.80 not 2.81 but 2.80. The reason being that after upgrading to 2.80 the downgrader to version 1.5 will work with any motherboard.


    If you would like to check this stuff out for yourself check out this excellent guide....

    http://forums.qj.net/f-psp-hacks-9/t-guidethe-ultimate-downgrader-guide-90916.html
     
  7. mrmcman

    mrmcman Guest

    ok s'all good. i was just contributing a thot
     
  8. solidusxx

    solidusxx Member

    Joined:
    Apr 6, 2007
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    16
    Thanks, dont worry I did the research before I did anything, I successfully downgraded then upgraded to the latest custom firmware on my ta-082 motherboard :)
     

Share This Page