1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TMPG says cannot open unsopported AVI

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by k0k0m0, Mar 7, 2005.

  1. k0k0m0

    k0k0m0 Regular member

    Joined:
    Mar 1, 2005
    Messages:
    671
    Likes Received:
    0
    Trophy Points:
    26
    I've posted the same question on another forum before realizing there was this forum http://forums.afterdawn.com/thread_view.cfm/166964

    I've got an AVI which TMPGEncoder refuses to accept, it says something like it's unsopported. Although I can perfectly play the movie on MediaPlayer, for instance.

    I've processed the AVI again with VirtualDub and TMPG still refuses to recognize it.

    Any idea what to do???
     
  2. k0k0m0

    k0k0m0 Regular member

    Joined:
    Mar 1, 2005
    Messages:
    671
    Likes Received:
    0
    Trophy Points:
    26
  3. aldaco12

    aldaco12 Active member

    Joined:
    Nov 6, 2002
    Messages:
    2,544
    Likes Received:
    0
    Trophy Points:
    66
    If the problem only lies in the audio, simply open the movie with VirtualDubMod and do Stream___Stream List. After that, you know which type of unsupported audio you have.
    Then you can either install the needed audio codec or simply convert AC3 ---> MP2 for SVCD (for instance) with BeSweet + BeSweet GUI...
    The .MP2 audio is much smaller than the .AC3 audio (50 MB compared to 170 MB, for an average movie, for instance, because AC3 is 'Dolby Surround') and can be loaded by TMPGenc without any plugin...if you just care about (S)VCD, wich use MP2 only, it works fine....
    But the message 'cannot open..' appears only if you don't have the video codec (e.g. DivX) , if you just miss the audio codec TMPGenc leaves the 'audio input' line in the front page blank. Strange!
    Just FYI, if the movie is an .ASF, some old version of TMPGenc cannot load it...unless , as in http://forums.afterdawn.com/thread_view.cfm/3843, it's a VFAPI plugin problem...
     
    Last edited: Mar 7, 2005
  4. k0k0m0

    k0k0m0 Regular member

    Joined:
    Mar 1, 2005
    Messages:
    671
    Likes Received:
    0
    Trophy Points:
    26
    I somehow solved this problem like this...

    But now, TMPG says it's gonna take 46 hours to process my file!!! Can it be that it takes so long for merely 1:30 hs of film?
     
  5. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    See my post in your other thread.
     
  6. 23sgte

    23sgte Member

    Joined:
    Mar 12, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Could anyone clarify please:
    How does one raise the priority of the direct show media file reader?
    The faq entry says to click tabs etc...
    Where are these tabs located?
    Perhaps I misunderstood, but I thought that direct show ran in the background and was similar to a mp3 decoder. eg. no adjustments necessary, or possible.

    If anyone could point me in the right direction, I would appreciate it.
     
  7. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Open tmpgenc, cancel the wizard.
    Click Options, Environmental settings.
    Right click DirectShow, select Higher.
    Do that until it's top of the list.
     
  8. 23sgte

    23sgte Member

    Joined:
    Mar 12, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Thaks rebootjim.

    I got it to the top of the list.
    I still cant get the sound, it seems that TMPG wont accept the source avi as an audio source. TMPG works for other avi files...

    Needless to say, the file plays fine.

    I will do a bit more reading here, and start my own thread if I am still stuck.

    Thanks
     
  9. aldaco12

    aldaco12 Active member

    Joined:
    Nov 6, 2002
    Messages:
    2,544
    Likes Received:
    0
    Trophy Points:
    66
    There are many reasons for the AVI not being accepted as an audio source. AC3 sound, for instance.
    If tou have the AC3 ACM plugin installed, TMPGenc can decode it. Otherwise:
    1) open the AVI with VirtualDubMod.
    2) do Stream___Stream List ___ Demux (you cannot 'save WAV' if you don't have the proper decompressor installed; if you select 'save WAV' probably you'll save a - small therefore fake - 200 MB 'WAV') and extract the audio stream (it should be AC3 sound or any compressed format)
    3) convert it to 'MP2 for SVCD' the BeSweet (+ BeSweet GUI)
    4) use that MP2 as 'audio input' when you use TMPGenc

    And... next time open a different thread for your questions, please. Do not overlap to others' questions.
     
    Last edited: Mar 13, 2005

Share This Page