1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TMPGEnc color encoding errors

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by tudor, Feb 23, 2005.

  1. tudor

    tudor Member

    Joined:
    Feb 22, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    I'm trying to encode a divX 5 file that plays fine in media player.

    I start encoding but the colors come out very wrong. I'm encoding at the highest possible quality level and a high bitrate but this is what I see:
    on the screen there are large blocky lines that are colored in what seem like basic colors: magenta, green, orange etc. the lines follow some contours of the image underneath, they are not completely random.
    this only happens with this particular file

    what am I doing wrong?

    avicodec reports 532 Kbps for the video, 23.976 fps, 638x350 (16:9), DX50
    audio is MP#.

    I tried changing aspect ratios in TMPGEnc, didn't make a difference

     
  2. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Encode at 23.976 and add pulldown from the "Encode Mode" dropdown box.
    Try top field first from the "field order" dropdown box on Advanced tab.
     
  3. tudor

    tudor Member

    Joined:
    Feb 22, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    it doesn't matter what I change, result is the same (tried changing random things too, like aspect ratio and resolution)
    the file has a funny resolution, 638x350

    WinDVD creator turns it into an MPEG but I don't like it because I can't change anything, it will make a 5 gig file that looks like crap (the original looks fine in media player but the resulting mpeg is very wide) and reencoding it in TMPGenc will probably make it even worse

    this is what I see: the screen is divided into horizontal lines. when the 3D Universal logo starts to show, the top line is somewhere, the one under it is a bit to the right, the one under that one is even more to the right etc. blocks of the screen are shifted right fron top to bottom.

    I also tried making a VCD with the wizard, same thing happens

    every other program (like ULEAD ones) encodes it OK but none offer any control on the encoding quality/settings.
     
  4. tudor

    tudor Member

    Joined:
    Feb 22, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    here are examples

    [​IMG]
    [​IMG]
    [​IMG]
     
  5. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Send me a 2 minute clip from it.
    ONE TIME ONLY JUNK EMAIL ADDRESS: dvdeo@shaw.ca
     
  6. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Is this the tmpgenc result, or the original file?
    I need a clip of the original file.
     
  7. tudor

    tudor Member

    Joined:
    Feb 22, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    this is TMPGenc result

    how can I split a bit of the original AVI? (while keeping the original problem in the file, if there is one)
     
  8. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    I see that you got it figured out.
    Back with some results in a few minutes.
    Totally strange.
    I can encode it in Mainconcept no trouble.
    I can encode it in Canopus Procoder no trouble.
    CCE Basic chokes just like tmpgenc plus 2.5
    Tmpgenc DVD source creator craps (locks up).
    Uses ffdshow DivX5, mpeg-4 (on my system) to render video.
     
    Last edited: Feb 23, 2005

Share This Page