1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TMPGEnc Plus Problem

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by hestar, Apr 18, 2005.

  1. hestar

    hestar Member

    Joined:
    Jul 21, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    16
    Using TMPGEnc Plus 2.5:
    The problem lies after selecting the file (where there is no problem and no error message is displayed) and going to stage 4/5 on the project wizard (bitrate setting).
    Here it tells me the estimated file size will be 153.56% of the disk size. Average video bitrate is 2000kb/s, and i cant reduce it to any less. Audio bitrate is 384kb/s.
    [​IMG]
    The problem seems to be in the fact that its telling me that the length of the video file is 371mins, even though i know it is only 140minutes long (which is shown in Windows Media Player and other video playback software). So somewhere along the line, it is recognising this video as a lot longer than it should be, so the output file will be too large.
    This now happens to all my AVI files i am trying to use, where with each file, the recognised source length is well over 2 times what it should be.
    I don't know why this has suddenly happened, because two weeks ago this software was producing output files with no problems. I have tried updating the program software, but i have had no luck with that. It just seems strange that any other video playback software i use sees the video length as what it should be, its just TMPGEnc Plus which sees it as longer than it is.
    Thanks in advance for any advice you can give me.

     
  2. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    This happens because of VBR MP3 audio.
    Here's the quick fix:
    Get virtualdub.
    Open the avi.
    Click NO to rewrite the header when prompted (if that fails, click YES the next time and try again)
    Select Audio, Full Processing.
    Select File, save .wav
    Give it a name and save it somewhere.
    Start tmpgenc, select the avi as normal, then select the .wav file you just saved as the audio source.
    Set audio bitrate to 224kbps (or even 192 is usually lots).
    You should now be able to adjust video bitrate to about 97% of disk capacity.
    This leaves a little room for authoring with menus and such.
     
  3. hestar

    hestar Member

    Joined:
    Jul 21, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    16
    Ok cool, thanks reboot.
    And by using your method, would i get a long black screen after the main movie has finished? or would the new .wav file stop this happening now?
    And one last thing, do you know why its happening to all my avi files? (..most of which aren't related to each other and all have different bitrates for video (divx/xvid) and audio (most mp3s).)
    Thanks again for ur help

    Edit: I tried doing it with a video file with the ac3 stream extracted, but after TMPGEnc converted the video file (which it recognised as the right length :D), it was out of synch with the ac3 audio. Again, this never happened before, and i guess it's related with the previous issue. If it isn't related, I'll start another thread.
     
    Last edited: Apr 18, 2005
  4. aldaco12

    aldaco12 Active member

    Joined:
    Nov 6, 2002
    Messages:
    2,544
    Likes Received:
    0
    Trophy Points:
    66
    Audio problems:

    1) If TMPGenc loads the uncompressed WAV as 'audio input', the length of the sound will match the video one, i.e. tere'll be no black screen at the end, as you were afraid of
    2) The un-sync problem happens to all the AVI files which contain VBR-encoded MP3 audio, and doesn't happen on the AVI which contain CBR-encoded audio streams
    3) If you load the AC3 stream you must take into account the 'delay'. Usually, when you rip an AC3 audio stream, you can see something like:
    AC3 2-ch english DELAY: 200 ms

    which means that you must there's a fixed A/V delay which ust be removed by delaying of the same amount the audio stream. Sometimes that amount is equal to zero, but sometimes it is a fixed amound (some hundreds of milliseconds). I do't knoew how to solve it, usully some authoring applications take this into account autmetically. Probably it's for this reason that there is a 'delay' option in HeadAC3he and BeSweet(+GUI).
     
    Last edited: Apr 19, 2005
  5. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Ah yes...delay crap/VBR audio. It would be so nice if everyone encoded all their avi's identically (with CBR audio), but that's never going to happen.
    The easy fix, is to select the video source as normal, but then select the newly extracted .wav as the audio source in tmpgenc, and then encode.
    Sometimes this can correct the sync delay.
     
  6. hestar

    hestar Member

    Joined:
    Jul 21, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    16
    It seems that the audio-video synch problem comes from after joining a 6-part file into one big file using VirtualDub and the "append segment" tool. I then extracted the ac3 audio, and saved the new avi file.
    This new avi file was now out of synch with the ac3 audio, so it must be a problem with VirtualDub.
    Another weird thing was that the audio-video synch seemed to get worse as the playing time went from start to finish. So at the start of the movie the synch was fine, but by the end there would be a 4 second delay in the video.
    Here's the details of the xvid/ac3 file if it helps (it is the first part in 6):

    [​IMG]

    I don't know if this problem is common with VirtualDub, but like the TMPGEnc problem, it seems to have happened so suddenly, and never happened with any previous files.
    Is there any chance that the TMPGEnc recognission of the file as too long and the audio-video synch problem with VirtualDub could be related? Maybe some issue with a codec or something? (which i don't know what it could be because i haven't made any changes to my codecs)
    Thanks for your help aldaco and reboot, its greatly appreciated :D Ive been stuck with these problem for a while now lol.
     
  7. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    This is a half D1 PAL video, with AC3 audio.
    If you're making a PAL DVD from it, there should be no trouble.
    If you're making an NTSC DVD from it, then everything can go south, including audio.
    It's not a virtualdub problem, more likely a PAL to NTSC conversion problem.
    Providing you have the AC3 decoder installed, it should encode.
    Sync is a whole different issue, and if it's a progressive sync problem, then it's even more difficult to fix.
     
  8. hestar

    hestar Member

    Joined:
    Jul 21, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    16
    I was making a PAL DVD with TMPGEnc, so it's not a problem with converting from PAL to NTSC.
    So with avi files with mp3 sound, i need to extract the sound in VirtualDub and save it as a .wav, and open both .avi (without sound) and .wav in TMPGEnc.
    With avi files with AC3 sound, i can try just opening the AVI/AC3 file and because i've got the AC3 codec, TMPGEnc should recognise the sound file accordingly.
    That way TMPGEnc should recognise the avi/wav file without adding on all the extra hours at the end (because maybe the VBR issue has been sorted?), and with the avi/ac3 file, it should stop the un-synch problem. (I'll be able to test these tonight (GMT))

    The only reason i originally wanted to extract the ac3 file and then just convert the video AVI in TMPGEnc, is because i can then use the ac3 file when authoring in TMPGEnc DVD Author and keep the surround sound. But i think i can live without that for a bit until i get this un-synch problem.

    One very last thing - in TMPGEnc, what audio mode should i be chosing? because so far ive been using CBR Mp2 option.
     
  9. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    CBR mp2 is fine.
    If you want to retain the AC3, load the file into virtualdubAC3 (not the normal Vdub), and demux.
    This will save out the AC3 audio, which you can then import into TDA.
    The mp3 audio ones, you must rip to .wav
    Even when encoded, they'll probably end up out of sync.
    Again, you can transcode the .wav to AC3 in something like ffmpeggui, and then load it during authoring.
    If it needs adjusting for sync, load the .wav into Goldwave or Soundforge, and adjust, then save it out as .wav and then transcode to ac3 or mp2, and load during authoring.
     
  10. hestar

    hestar Member

    Joined:
    Jul 21, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    16
    The out of synch problem only happens with the xvid/ac3 file, not the avi/mp3 file.
    So far i've managed to find this site (http://www.digital-digest.com/dvd/downloads/showsoftware_virtualdub_346.html)
    which has VirtualDubAC3 at the bottom of the page, but with this program, i can't find the Demux option for the AC3 stream. Do i need a different program? or am i just being a real noob and can't find it anywhere.
    The only thing i can think of doing is going to File, and then save .wav, where i changed the filename to Sound.AC3, then going to Audio --> No Audio, and then saving the AVI as Video.AVI
    Thanks
     
  11. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Sorry, I should have typed VirtualdubMOD not ac3.

    Click Streams, stream list, then RIGHT click on the stream you want.
     
  12. hestar

    hestar Member

    Joined:
    Jul 21, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    16
    Oh right, that makes little more sense :D
    Well that was the program i was using before, and still gave me an out of synch xvid video and ac3, but it turns out it goes out of synch after appending all the video segments. I tried just appending all 6 files, and saved them as one AVI, and it was out of synch.
    Do you have any ideas why VirtualdubMod what make it out of synch just by appending the videos, even if the individual videas are all ok in the first place?
     
    Last edited: Apr 21, 2005
  13. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    The join is what's causing it.
    Wherever the file was joined, there's an audio gap (audio comes BEFORE video), or an audio overlap. Because the audio track can't overlap, it just shuffles further up (audio comes AFTER video).
    Once demuxed, you can try to manually fix it. Sony Soundforge would be ideal for this, because it also loads the video, so you can see and hear how much delay you need to add, and where.
    It would be easier to encode each of the 6 parts separately, to keep sync, then author them together.
     
  14. hestar

    hestar Member

    Joined:
    Jul 21, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    16
    Ah that makes sense, except that the audio does come before the video.
    That would also explain why it the audio-video synch gets progressively worse.
    So I'm going to try extracting the AC3 audio from each of the 6 video files, and encode each of the xvids individually in TMPGEnc.
    Then in TMPGEnc DVD author, add each of the 6 encoded files as 6 tracks, and add each AC3 audio file to each track.
    And if it then works i'll be very happy, thanks for you help and patience thro this :D
     
  15. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Check each for sync before authoring.
    You may have to add a delay to the beginning of audio, but the sync should be standard (if it's 1 sec out at the beginning, it will be 1 sec out at the end) and not progressive.
    You can check sync by loading the m2v into virtualdubmod, then select Streams, stream list, add, and load the AC3. Then play it.
     
  16. hestar

    hestar Member

    Joined:
    Jul 21, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    16
    The mp3 audio encoded video files are working fine now (once i use VDub to save the mp3 as an uncompressed wav).

    But now i've got a problem with an ac3 encoded file.
    When i try to demux the ac3 audio stream from the avi files, the ac3 output file seems to be corrupt after demux, and every program ive tried (VDub, BSPlayer, Nero Showtime) all say that the file is either incompatible, illegal or corrupt, although VDubMod demuxes the stream fine and no error message comes up during or after the process.

    Do you have any ideas as to why i'm getting this issue?
     
  17. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Have you got the AC3 codec?
    If not, try it.
    Otherwise, save a .wav just like all the others.
     
  18. hestar

    hestar Member

    Joined:
    Jul 21, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    16
    Yeah ive got the codec, the problem only happens with this one file, although the audio plays from the original file with no probs.
    I guess i can just save it as a .wav.
     
  19. Koala

    Koala Member

    Joined:
    Jun 13, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    I had the same problem with a file, i just used the edit source range and "reminded" tmpg where the end of the movie was and it was fine, I know you shouldn't have to do that but we have to compromise our principles at some time
     
  20. hestar

    hestar Member

    Joined:
    Jul 21, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    16
    Wow, movie files with mp3 sounds now work fine! great idea lol, no idea why it kept thinking the file was longer than it actually was :D thanks alot for that
     

Share This Page