1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TMPGEnc user problem

Discussion in 'DVDR' started by wuzzbert, Dec 11, 2003.

  1. wuzzbert

    wuzzbert Member

    Joined:
    Oct 9, 2003
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    16
    I am having a problem using TMPGEnc to convert an .avi file (I downloaded off torrent) to a DVD MPEG2 file. The file is 869mb and the codec is XviD.

    I use the wizard to set up BUT when I get to the birate settings the file size shows 114% in red letters and will not let me reduce it to 98% to 99% as idicated in a guide I'm using which can be found at: http://www.polarhome.com:793/~afonic/tmpegenc.htm

    What is wrong, I think it's because the .avi file is too big to be converted, is this the case, if so how do I get round it?

    Cheers
     
    Last edited: Dec 11, 2003
  2. Yuriv

    Yuriv Regular member

    Joined:
    Apr 10, 2003
    Messages:
    383
    Likes Received:
    0
    Trophy Points:
    26
    TMPGEnc does have a minimum bitrate that it allows for DVD, so your video could just be too long to fit on a DVD-R at the minimum bitrate allowed.

    You can do one of two things:

    1) Cut out the opening and closing credits (can be done within TMPGEnc's encoding options) and see if it will fit.

    OR, if it won't

    2) Go ahead and convert the file even though it will end up too large.

    Next, author the title-set and again ignore any messages saying that the file will be too big to burn to a DVD-R.

    Finally: Use DVDShrink to compress the title set so that it will fit on a regular DVD-R.

    Problem solved!
     
  3. wuzzbert

    wuzzbert Member

    Joined:
    Oct 9, 2003
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    16
    What I can't get my head round is why a file 869mb big won't fit on a 4.7G disc.

    Can you explain?
     
  4. Yuriv

    Yuriv Regular member

    Joined:
    Apr 10, 2003
    Messages:
    383
    Likes Received:
    0
    Trophy Points:
    26
    The size of the output file will depend on two things: 1) the length of the film (in mins and secs); and 2) the bitrate used. A bitrate sets out how much information will be used to encode each second of video: at 200kb/sec, a 1 minute clip of video will encode to be 12,000kbs regardless of the size of the original file.

    Thus, the size of the original file has nothing to do with it - a 1hr AVI video file that is 500MBs could be re-encoded to a 150Mb MPEG2 file or to a 1.5Gb MPEG2 file, depending on the bitrate used.

    TMPGEnc Sets a minimum bitrate of 2000Kb/sec when you use the wizard to set up your encode. This means that you should be able to get about 4 hours of video onto the DVD-R.

    In your case one of several things is going on:
    1) Your video is very long;
    2) Your video is quite long and you are using the PCM audio option (which takes up more space than the MP2 option)
    3) Your AVI file is misreporting how long it is, so that TMPGEnc is being fooled into thinking it is a bigger project than it really is. I have had this happen before.

    In either of the first two cases, my earlier suggestion still stands.

    However, I hadn't thought about the third possibility earlier, so if you are sure the file is not extremely long you may have to manually set the bitrate before beginning your encode.

    Open the file in Virtualdub or WMP and check how long it is (scroll through to the end). Next go to:

    http://www.guygraphics.com/index2.html

    And enter the actual video length and setting the audio bitrate that you are going to use using, set the type to 1 DVD disc, and make note of the bitrate it recommends that you use.

    Next, setup TMPGEnc via the Wizard, and allow it to stay above 100% when setting the size. However, on the last screen, deselect "begin encode immediately" and allow it to exit the wizard. Next, go to the "settings" window (bottom right) and under the "video" tab, enter the proper bitrate as reported by the calculator (a little lower to be safe).

    Press Start, and you should end up with a file of the right size.

    Once again, good luck!
     
    Last edited: Dec 11, 2003
  5. wuzzbert

    wuzzbert Member

    Joined:
    Oct 9, 2003
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    16
    ok I will give it a go, BTW the movie is 1hr 40 mins.

    I am using PAL and selecting CBR MPEG-1 layer ii audio (MP2), not sure what this means. I am simply following the tutorial at the link I left in the first post in this thread.
     
    Last edited: Dec 11, 2003
  6. wuzzbert

    wuzzbert Member

    Joined:
    Oct 9, 2003
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    16
    Sorted!!!

    The problem is that there is a corrupt frame (the second one from the end) and TMPGEnc encoded my film into 8hrs 23mins for some strange reason. So I have cut the end off and it's worked a treat.

    Cheers for the advice, I'm learning fast!!!
     

Share This Page