1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrading a flashed xbox 360 from unknown firmware to LT 2.0

Discussion in 'Xbox 360 - Modding & Hacking' started by KaushikDB, Oct 24, 2011.

  1. KaushikDB

    KaushikDB Member

    Joined:
    Oct 2, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    11
    I got my Xbox 360 arcade with pre flashed BenQ drive for about 1 year, but still I am newbie to this flashing ,modding ,hacking. I have read some stuff on the net about flashing, about Jtag, about softmods.

    The new XGD3 games needs the LT 2.0 firmware, and I probably I don't have that, as I bought the console for about 1 year. I have read about Jungle Flasher. But still is in the confusion, so will the grateful if somebody clears that to me. Here's my questions.


    1. As I got the console pre-flashed, so I don't know what firmware it's using. And I don't have the stock firmware files. Now, is it necessary to know that firmware version if I want to update that to LT 2? And do I need the stock firmware files or something similar to update the current firmware? The procedure that I found all over the internet is probably to flash the stock firmware to LT 2.0. Is the process is same for those drives( I mean like mine), that's already flashed( I mean it doesn't have the stock firmware, so is the process same if it has a different firmware?)?


    If it requires a different process then please give a link to a tutorial, or at least give the term that I should google to get that different process.



    2. Is there anything have to do with the dashboard version?
    My current dash is 2.0.12611.0

    3. It's kinda irrelevant to ask it here, still.

    I don't use live anyway, so I want to downgrade my dash. Is it possible? I can't play black ops, Assassins creed for the update.
     
  2. funksoulb

    funksoulb Regular member

    Joined:
    Oct 4, 2008
    Messages:
    1,713
    Likes Received:
    0
    Trophy Points:
    46
    1. The stock firmware files come with the full download of LT+ 2.0. All you need is your key, which you can extract from the drive, so it doesn't matter that you don't know what firmware is on there now or that you don't have a backup of your original firmware.

    The process you need to follow is this: -

    a) Dump key and flash back to stock firmware
    b) Update dashboard to latest version
    c) Flash to the latest LT+ version for your drive

    All of the info for doing that is in the downloadable JungleFlasher guide. BenQ drives are one of the easiest to flash too, so you're in luck.

    2. You need to update to the latest dashboard version after flashing back to stock firmware.

    3. You can't downgrade the dashboard.

    The other thing to bear in mind is that if you have backups of any of the 6 XGD2 AP2.5 games, you'll need to run them through abgx360 to ensure they're fully patched and up to date or they won't boot and trying to boot one of them will flag your console.
     
  3. KaushikDB

    KaushikDB Member

    Joined:
    Oct 2, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    11
    Thank you funksoulb for the information. But I got little more questions.

    Why is it necessary to update the dash to the latest version?
    And I don't play live. My console got online only for a few time when I tried the 1 month gold trial, and I don't plan to connect to live.
    And as the updates has new security checks for back up games, some back up may not run in my console. Like I played black ops, and just after the update it says "Unreadable disk".
    So, my question is,

    1. Isn't it foolish to update dash?( At least for me, as I don't go live)
    2. And my console doesn't run backed up black ops for the dash update I did last time. So, my console is never ever gonna play a black ops game disk?


    Thanks in advance.
     
  4. shai12

    shai12 Member

    Joined:
    Aug 3, 2006
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    16
    If you want to play the latest games you have no choice but to update
     
  5. KaushikDB

    KaushikDB Member

    Joined:
    Oct 2, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    11
    I feel that's right. But it'll just restrict me from playing some games sometime. You're right, no choice.
     

Share This Page