1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrading to Devhook 0.52 from 0.51

Discussion in 'Sony PSP - Mod and firmware discussion' started by leman, Jan 31, 2007.

  1. leman

    leman Member

    Joined:
    Jan 31, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    The Short Version:
    My PSP is running firmware v1.50 with Devhook 0.51 emulating firmware v3.02. I want my PSP to be running firmware v1.50 with Devhook 0.52 emulating Dark Alex's custom firmware "v3.03 OE-C".

    The Long Version:
    A couple of months ago I learned of the 2.71 downgrader for the PSP, so I bit the bullet and risked downgrading my PSP to a v1.50 firmware and I haven't looked back. I've used homebrew to make my PSP into a TV remote, a streaming video player, and a console emulator (SNES & Megadrive). Now I've read about the PSP being capable of playing PSX games, so I'd like to get it to do that too. I already have Devhook 0.51 installed, which I used to emulate firmware 3.02. Now I'd like to take it a bit further and switch to the latest Devhook (0.52, I believe) and make use of Dark Alex's 3.03 OE-C custom firmware so that I can emulate the PSX versions of Silent Hill & FF VII. However, I don't quite know how to go about clearing out Devhook 0.51 from my PSP to make room for the newer version. Basically, I'd like to take the PSP back to the state it was in the moment I'd finished downgrading to v1.50 firmware.

    Any advice would be much appreciated (preferrably in the form of a step-by-step guide with big pictures and as few long words as possible). ;D
     
  2. totulnoob

    totulnoob Member

    Joined:
    Jan 31, 2007
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    11
    can you please help me downgrade my psp from 3.03 to 1.50?? I really need help
     
  3. leman

    leman Member

    Joined:
    Jan 31, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Er, no, I can't. AFAIK it's not possible to downgrade a PSP if its firmware is higher than v2.80 (maybe only as high as v2.71). I'm afraid your only option as far as downgrading is concerned is to wait for someone to come up with a v3.03 or higher downgrader. Until that happens your only other options are to either buy an older PSP with firmware v1.50, or which can be downgraded, or have one of the "Undiluted Platinum" mod chips installed (though at the moment chipping costs over £100, so it might be cheaper to try and buy a second-hand PSP from somewhere, rather than trying to have yours modded).
     
  4. leman

    leman Member

    Joined:
    Jan 31, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Just came across information on a 3.03 downgrader here:
    http://noobz.eu/

    Some of their notes:
    * This downgrader is for v3.03 firmware only. But if you have v2.81 - v3.02, no problem - you can just upgrade to v3.03 to use the downgrader.
    * You need a copy of the unpatched GTA:Liberty City Stories UMD. No ISOs, no patched UMDs, not Vice City Stories. See here for some info on how to check if your version is patched. The most reliable way : the unpatched disks have the v2.0 firmware update on them.
    * This downgrader is intended to enable homebrew. Homebrew is NOT the same as piracy. Don't be a thieving loser - buy the games you play.
    * The downgrader will work on all current PSP hardware (TA-079 - TA-086). Patching of TA-082+ is automatic in the downgrader.
    * You downgrade at your own risk. There is always a chance of bricking, although we have done everything we can think of to make this process safe.

    I can't say if it works, and I'm sure as hell not going to test it, but at least you now have the option to downgrade or not.
     

Share This Page