1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

USB 2.0 Issue

Discussion in 'Windows - General discussion' started by guessswho, Feb 14, 2008.

  1. guessswho

    guessswho Regular member

    Joined:
    Aug 21, 2007
    Messages:
    2,826
    Likes Received:
    0
    Trophy Points:
    46
    So I have a custom built computer. I just recently had to wipe it and reinstall everything. All the drivers are back on, and I finally got everything to work, except my USB ports. For some reason, windows is not detecting them as being usb 2.0. I know that they are for a fact. I have tried reinstalling my chipset drivers, but that didn't work. Anyone have any good ideas on how to get it working? Whenever I connect something to it, it goes and old USB speeds and is ssooo slow. Thanks for the help guys
     
  2. silk42

    silk42 Regular member

    Joined:
    Dec 21, 2007
    Messages:
    591
    Likes Received:
    0
    Trophy Points:
    26
    Are you using Windows XP? If so, install all of the Windows updates. After all of the updates are installed, go into the Device Manager and make sure your USB controller has the latest driver (it'll use the driver included in the service pack from MS). You can also check the website for your motherboard manufacturer, but most of them recommend using the drivers provided by MS.
     
  3. guessswho

    guessswho Regular member

    Joined:
    Aug 21, 2007
    Messages:
    2,826
    Likes Received:
    0
    Trophy Points:
    46
    yeah I'm running XP. I've already updated windows as much as I can, and I also have gone to the motherboard site (it's an ASUS) to redownload all the drivers, and I reinstalled them, but to no avail unfortunately.

    Any thing I might be forgetting?
     
  4. steimy

    steimy Active member

    Joined:
    Dec 2, 2004
    Messages:
    12,030
    Likes Received:
    1
    Trophy Points:
    96

Share This Page