1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

USB External Harddrive cannot be recognised by my laptop any more, i need help!!!!

Discussion in 'PC hardware help' started by pwhile, Dec 27, 2007.

  1. pwhile

    pwhile Member

    Joined:
    Dec 31, 2005
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    11
    Hope someone can help me here!
    I have an external 250GB Harddrive that i have been using for over a year for storing all kinds of data & files including my music collection when syncing my ipod.

    Few days ago i went to plug my harddrive into my laptop (through USB) and when the power kicks in i get message on my desktop (im using Windows XP) saying something like - "Cannot read, hardware maybe corrupted - click here to fix" - when i click on the link i get passed to a window that has driver options...

    I have done everything from uninstalling, reinstalling drivers.. Ive looked on the official website for any updates and im getting no where. Ive tried this harddrive on another computer and i am getting the same problem so its definately the hardware and not the computer.

    Does anybody know how i can get it running and recognised by windows again? I really cant afford to lose the data/files on this harddrive.

    Thanks in advance
     
  2. phill2000

    phill2000 Guest

    I had something similar with one of my external harddrives.

    It said the device was no longer recognized, so I plugged it into a different USB port after removing the device from hardware manager, then letting it reinstall it.

    When it stopped working again, I tried the above method and it didnt work, so I plugged it into another pc, copied all the files across. Fully formatted the disk, transfered everything back and it was fine.
     
  3. sammorris

    sammorris Senior member

    Joined:
    Mar 4, 2004
    Messages:
    33,322
    Likes Received:
    5
    Trophy Points:
    118
    I would also recommend the method that Phil suggests, but I have to say, if it's important, back it up!
    If you don't have any luck there are programs (and services) that can recover data off faulty drives. The programs are relatively inexpensive, but the services certainly aren't.
     
  4. pwhile

    pwhile Member

    Joined:
    Dec 31, 2005
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    11
    Still no joy..

    Heres a screenshot of the message i get:

    [​IMG]

    i have now taken apart the external hardrive casing & will try connecting the actual hardrive disk to a computer
     
  5. sammorris

    sammorris Senior member

    Joined:
    Mar 4, 2004
    Messages:
    33,322
    Likes Received:
    5
    Trophy Points:
    118
    That's almost certainly an issue with the hard disk enclosure, and not the drive itself, else the USB device would probably be recognised, but there'd be no drive in My Computer. It sounds like all you need is a replacement enclosure.
     
  6. BIGTOXY69

    BIGTOXY69 Regular member

    Joined:
    Jul 16, 2004
    Messages:
    2,851
    Likes Received:
    0
    Trophy Points:
    46
    Yup I get the same message now with any usb device except my mouse when I plug my usb Gear - Printer ,external HDD , External dvd Burners ect... all seem to work any be recognized by my Laptop just fine ! Tryed Uninstalling and letting the computer find the usb gear but still get same messages on all 6 usb jacks ( Emachines W2040 if that info helps ! any ideas other than reinstalling windows????? Thanx
     
    Last edited: Dec 27, 2007
  7. sammorris

    sammorris Senior member

    Joined:
    Mar 4, 2004
    Messages:
    33,322
    Likes Received:
    5
    Trophy Points:
    118
    Sounds like the USB driver has been messed up by something. Go the download section of the emachines website and redownload the "Chipset Driver" unless there's a specific USB driver, in which case get that.
     
  8. BIGTOXY69

    BIGTOXY69 Regular member

    Joined:
    Jul 16, 2004
    Messages:
    2,851
    Likes Received:
    0
    Trophy Points:
    46
    sammorris- Thanx everso much!!! - I guess old age is catching up with me I did'nt even think to do that ! Happy New year early sammorris!!! & thanx again
     
  9. pwhile

    pwhile Member

    Joined:
    Dec 31, 2005
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    11
    Ok i bought i new external hardrive enclosure today and is working beautifully now :)

    All my data is safe!

    Thank you for your help guys!
     
  10. sammorris

    sammorris Senior member

    Joined:
    Mar 4, 2004
    Messages:
    33,322
    Likes Received:
    5
    Trophy Points:
    118
    Sure no worries. Happy new year, for a few days time... I'll be away for the week so I'll get that in early!
     
  11. BIGTOXY69

    BIGTOXY69 Regular member

    Joined:
    Jul 16, 2004
    Messages:
    2,851
    Likes Received:
    0
    Trophy Points:
    46
    some good news some bad - contacted Gateway/Emachines - on live chat the firs tech was truly helpful and explained how to reset my usb drivers and restore my Defaults setting in my bios ! Well If I follow his instructions to restore my defaults I get my usb back but just 1.1 USB and not USB 2.0 That it's supposed to be ! But I lose my ethernet connection ( No internet) If I use the Optimized defaults setting I get my internet back but my Usb go Awry ( Unknown device errors & Usb gear does'nt work so Go figure !I contacted Emachines/Gateway on live chat again to explain what was going on the Tech a Young Woman immediately wanted to start talking UPGRADES- I explained that I've already added a 500GB HDD, 2 DVD Burners , and 1 GB of Memory and I was more interested in fixing my problem 1st! Perhaps I pissed her off ? I don't know but she seemed to flounder somewhat after that point ! with out offering much more help after my statement ! Other than to say try a Complete reinstall or Bring it to the shop ! I replaced the original motherboard & Ps so the Emahines restore disc isn't going to cut it ! Maybe it's time 4 a new unit But I would like XP and not Vista !!! so I guess that would be a special order ? Anyway thanx again & Happy New Year!!!!!!!!!!!!!
     
  12. sammorris

    sammorris Senior member

    Joined:
    Mar 4, 2004
    Messages:
    33,322
    Likes Received:
    5
    Trophy Points:
    118
    Do you have the service packs for XP installed? I think with SP2, you don't even need a USB driver to get USB2 functionality. Of course it could be that there's a fault with your USB chipset in that it can't recognise devices over USB. If that's the case you may have to replace the laptop. As for getting a new one with XP, shop around, some places will probably happily do that.
     
  13. hoak

    hoak Member

    Joined:
    Jan 9, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    I HAVE QUESTION!
    BEFORE I USE EXTERNAL HARD DRIVE PLUG IN ANY USB 2.0 AT PC,
    ANY WORD FINE,ABOUT 2 WEEK AGO I PLUG IN MY EXTERNAL HARD DRIVER
    80GB AT PC ,THEN PC SHUTDOWN AND I USE ANOTHER PC PLUG IN AGAIN
    EXTERNAL HARD DRIVER SAME PROBLEM,AWAY PLUG IN PC SHUTDOWN,
    WHAT HAPPEN,ANYONE KNOW PROBLEM,HELP ME.
     
  14. sammorris

    sammorris Senior member

    Joined:
    Mar 4, 2004
    Messages:
    33,322
    Likes Received:
    5
    Trophy Points:
    118
    Sounds like the enclosure's faulty. The drive inside may be OK, but the circuitry for the box it's in may have broken. Try to find a replacement enclosure.
     

Share This Page