1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Using MeGUI to Encode help

Discussion in 'Convert DVD to another format' started by Z_Man22, Jun 16, 2012.

  1. Z_Man22

    Z_Man22 Member

    Joined:
    Apr 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    I have used MeGUI to rip a few anime DVDs (16:9 at 2000 bitrate with deinterlacing, the show was from 2005 I think) and those look great. Now I am trying to rip my Gundam 00 dvds and have run into a few problems. I've tried both 3000 bitrate which gives me this:
    http://www.sendspace.com/file/4rq5sa

    Obviously not wanting such blocks in my final file, I tried again at 4000 bitrate and got these:
    http://www.sendspace.com/file/2g0wju and http://www.sendspace.com/file/iu3g96

    The blocks are still there. Why? Is there some setting that I'm not aware of? Am I just not using a high enough bitrate? This also occurs on a DVD of a series from 1990. I know that there is no way that THAT could be HD video, so why would that also do it? I'm not an expert but have learned a bit from changing settings over many encodes, but this problem still persists. I managed to subdue interlacing, but now cannot get rid of blocky artifacts. Any help would be greatly appreciated.

    Thanks in advance.
     
  2. Z_Man22

    Z_Man22 Member

    Joined:
    Apr 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
  3. scorpNZ

    scorpNZ Active member

    Joined:
    Mar 23, 2005
    Messages:
    3,990
    Likes Received:
    40
    Trophy Points:
    78
    Why the hell would anyone want to use those links just to be redirected to download some other crap called livid wtf you try'n to pull,not wasting my time you got screen shot to show host it normally like everyone else in the mean time have a spam report from me

    unsubbed
     
  4. Z_Man22

    Z_Man22 Member

    Joined:
    Apr 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Yeah, and how do I do that? Thanks for being a real ass.

    Nevermind, I found Imageshack. Here are my pictures.

    This is what happens with the Gundam 00 file:
    http://imageshack.us/photo/my-images/692/vts051muxedmkvsnapshot0q.jpg/

    and this is the other file:
    http://imageshack.us/photo/my-images/705/vts011muxedmkvsnapshot0.jpg/

    Notice the bottom of the second file. That is what I'm trying to get rid of.
     
    Last edited: Jun 18, 2012
  5. ddp

    ddp Moderator Staff Member

    Joined:
    Oct 15, 2004
    Messages:
    39,014
    Likes Received:
    78
    Trophy Points:
    128
    Z_Man22, watch the name calling.
     
  6. hello_hello

    hello_hello Member

    Joined:
    Mar 14, 2012
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    16
    Instead of selecting a bitrate, try using quality based single pass encoding. MeGUI defaults to a value of 20 which should look pretty good (18 is supposed to be around where x264 is transparent). Higher CRF/Quality values lower the quality.
    Obviously when running single pass quality based encoding you have no say on the bitrate or final file size, but that's kind of the point. The quality relative to the original video should be fairly consistent for a given quality setting.

    These days most people (myself included) seem to run quality based encoding rather than running 2 passes. Unless you particularly need to hit a certain file size or bitrate then quality based encoding is the way to go, and it doesn't take anywhere near as long. You're not achieving better quality by running 2 passes as such.
     
  7. Z_Man22

    Z_Man22 Member

    Joined:
    Apr 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Tried this, but the same thing occurred with these settings:
    One pass, 20.0 quality
    Analysis showed this:
    ITU NTSC 4:3 (1.367377) same as original
    Source Type: Hybrid film/interlaced. Mostly film.
    Field order: Top field first
    Deinterlace: TIVTC
    Source is anime checked
    Noise filer = minimal noise

    screenshots: http://imageshack.us/photo/my-images/171/vts011muxedmkvsnapshot0.jpg/
    http://imageshack.us/photo/my-images/706/vts011muxedmkvsnapshot0.jpg/
    Still getting the same old crud.
     
  8. hello_hello

    hello_hello Member

    Joined:
    Mar 14, 2012
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    16
    It may be because of the noise filter. Personally I never use one. While noise filters can reduce the noise, they invariably reduce the fine detail to some degree in the process. Using a noise filter will often help reduce the file size a little (less noise = easier to compress) but each to their own.... aside from de-interlacing I generally just try to reproduce the original as faithfully as possible and encode "as-is".

    Try unchecking "Source is anime". I don't use it, although I don't encode anime very often. I can't remember exactly what the option does but I think it's supposed to save a little bitrate when encoding... possibly while increasing the chances of blocking. It wouldn't hurt to try an encode without it....

    Try a lower CRF value (Quality setting). I can't actually see your screenshots very well because my monitor seriously needs cleaning, but x264 does have issues with colour "banding" at times. I'm not sure if that's the cause, but a lower CRF value should improve it a lot. CRF 18 should be fine but if not CRF 16 should be even better, although the file size will probably be on the large side.

    Failing that, I recall a thread a while back over at doom9 where x264 banding/blocking was being discussed. There was a tweak for a couple of x264 settings which improved it without having to drop the CRF value ridiculously low. Off the top of my head I can't remember what they were, but if you don't have any luck with the above I'll see if I can find the thread for you. I'd try an encode without the anime option or noise filter at CRF 20, then if the problem's still there try again using a lower CRF value.

    Nothing to do with your question, but I'd be willing to bet at least 90% of DVDs don't use ITU resizing. An old anime 4:3 DVD is possibly more likely to use ITU resizing than a newer DVD, but MeGUI has a "use ITU resizing" option. Unchecked it won't default to ITU.
    For the record, pretty much all software players don't use ITU resizing when playing DVDs. If you compare an ITU resized encode with the original played using MPC-HC or something similar you'll probably see a slight difference in aspect ratio. Only you can decide whether a particular DVD uses ITU resizing or not. There's no way to know for sure.
     
    Last edited: Jun 19, 2012
  9. Z_Man22

    Z_Man22 Member

    Joined:
    Apr 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    For the ITU, in my previous post I listed the aspect ratio as ITU 4:3. The analysis automatically detected this so I left it alone. This is for the older (2001 of a 1990 show) DVD, my pics that are a white screen with the logo. Also, when first trying to encode both of these DVDs I did not have "source is anime" or "noise filter" enabled, but after I couldn't get it to work I tried them. A lot of guides said to use them, so I tried. Oh well.

    As for the CRF, I've always left it at 18 until somebody said try 20, so I did for a while. It's now back at 18.

    Please do see if you can find that thread. I would be interested to all the different tweaks it has to offer.
     
  10. hello_hello

    hello_hello Member

    Joined:
    Mar 14, 2012
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    16
    There's no way for MeGUI to know whether ITU resizing is used. It can't be determined by analyzing the DVD. MeGUI just knows if the DVD is 4:3 or 16:9. Whether it chooses 4:3/16:9 or ITU 4:3/ITU 16:9 simply depends on whether the ITU setting is checked in MeGUIs options.
    Personally I have it set to choose either 4:3 or 16:9 rather than the ITU 4:3 or ITU 16:9 as personally I don't think many DVDs actually use ITU resizing. The difference isn't huge. From memory a DVD has it's width stretched by around 2% more when using ITU resizing than when using straight 4:3 or 16:9 resizing. For years I encoded DVDs as AVIs without using ITU resizing and these days when I compare my old AVI encodes with the Bluray version (which just uses square pixels so there's no ITU to worry about), in the majority of cases not using ITU resizing seemed to be the correct choice. There has been a few exceptions where ITU would have been right, and I live in PAL-land so I've not encoded as many NTSC DVDs... anyway, it's just something I thought I'd mention.

    The tweak for reducing blocking seems to be this one:
    http://mewiki.project357.com/wiki/X264_Settings#aq-strength
    It can be found under the Rate Control tab when setting up the x264 encoder using MeGUI ("show advanced settings" checked). The default is 1.0 Try something a little higher (1.1, 1.2 etc) to see if it helps. There's also http://mewiki.project357.com/wiki/X264_Settings#aq-mode. If you change it to 2 you may have to then lower the CRF value a little to compensate.... I'm not sure. I'd probably set aq-strength back to default before changing aq-mode.... at least to start.
    The above wiki page explains (to a certain degree) all of x264's options. MeGUI also offers a tooltip for most of them.
    You could also try http://mewiki.project357.com/wiki/X264_Settings#no-dct-decimate

    My only other suggestion would be to try a slower x264 speed preset. The above settings (I don't think) change according to the speed preset used, but many other options do. I don't understand a lot of them enough to consider fiddling with them, but you can see which x264 settings change and how they do according to the speed preset used, as MeGUI automatically changes the appropriate advanced settings to their new defaults when the x264 speed preset is changed. Then if you're really keen you can look them up on the wiki page to see what they do, or see if MeGUI offers a tooltip. Personally I stick to the speed presets and whichever changes they make as I don't imagine I know any better.
    Good luck!
     
    Last edited: Jun 21, 2012
  11. Z_Man22

    Z_Man22 Member

    Joined:
    Apr 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Ugh, still getting the same results. Ok, here's what I tried:
    Unchecked the ITU option, since it wasn't really doing anything.
    Used the aq-strength option for several encodes, for values I used 1.2, 1.5 and 2.0.
    Used the aq-mode option at a value of 2.
    After both of these gave the same results I tried the "Slower" preset option and got the same result. Noticed afterwards that the slower preset uses aq-mode with a value of 2.

    This is taking forever and every option/tweak/whatever gives me the same result. The source video is fine and does not show such distortions. I am totally clueless.
     
    Last edited: Jun 22, 2012
  12. hello_hello

    hello_hello Member

    Joined:
    Mar 14, 2012
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    16
    Sorry but I seem to be out of ideas.

    Maybe you could upload a small sample of the original video for others to encode to see if someone can come up with a clever idea.
    I could have a play with it myself although I'm not sure I'd have any more success, but you never know...
     
  13. Z_Man22

    Z_Man22 Member

    Joined:
    Apr 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Here is a 15 second sample of one of the DVDs. I believe it's easier to see the distortion on the white background in this clip than in the other one (Gundam).

    http://www.sendspace.com/file/1p2t0f it's 12 MB. I did try to get a Gundam sample, but for some reason it kept giving me bad files. Huh, oh well.

    Also, I've noticed that when I play back certain MKVs (like an episode of another anime that I downloaded, a blu-ray rip) I get the same distortions. I am going to look into codecs next, but would anybody have any suggestions into which ones to look into or check first?

    Thanks in advance.
     
  14. hello_hello

    hello_hello Member

    Joined:
    Mar 14, 2012
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    16
    I just ran a quick encode using pretty much the default x264 settings and a CRF value of 20. I've not got much time to mess around today and I really, really need to clean my monitor (it's hard to see through all the dirt on the glass), but how does this screenshot look?
    http://www.sendspace.com/file/c7d1ws
    Or here's the encode. The source is fairly noisy but aside from that it looks okay to me. http://www.sendspace.com/file/hhvrap

    Maybe it is a playback problem. I'll admit that didn't occur to me..... I wonder if it's likely?

    Which media player are you using?
    Rather than install codecs, try Media Player Classic Home Cinema. "Out of the box" it comes with it's own internal filters for all the common formats so you don't need to install any system codecs.
    Does your media player use your video card for h264 decoding (DXVA decoding)? If your video card is capable of DXVA decoding then MPC-HC will use it to decode by default. You can disable the internal DXVA filters though and use the CPU for decoding instead.
     
  15. Z_Man22

    Z_Man22 Member

    Joined:
    Apr 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    I checked the MKV sample, and it shows the same blocking/distortion/whatever. I've been using MPC Home Cinema forever, and it does play 99.9% of things without problem. Only recently have I started to see the degraded quality in certain things.

    I'm going to try disabling DXVA and see what that gives me.
     
  16. Z_Man22

    Z_Man22 Member

    Joined:
    Apr 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Oh wow, I installed ffdshow and it fixed my problem. I looked at the encode you uploaded before and I still saw the blocks while looking at it after I installed ffdshow gave me a perfect vid. The vid does have a lot of noise, but that's understandable because it's a DVD of an anime from 1990.

    I'm glad that I found a solution to my problem, but dang did it take a long time. Thanks to everybody who tried to help. I'll definitely come here again if I need help with something.
     
  17. Z_Man22

    Z_Man22 Member

    Joined:
    Apr 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    ARGH, I am getting very frustrated. Now other files have what seems to be a layer of snow over them AND a few files still have blocking. Trying to encode another anime from about the same time that has blocks but they seem to be rather small. Might be because my screen is stretching the image.

    ...how do you disable DXVA?
     
  18. Z_Man22

    Z_Man22 Member

    Joined:
    Apr 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    While I would love to know how to disable DXVA just in case I run into a problem with it later on, the problem with the snow turned out to be the source I was using for one of my attempts. Please ignore that question.
     
  19. ps355528

    ps355528 Regular member

    Joined:
    Aug 17, 2010
    Messages:
    996
    Likes Received:
    10
    Trophy Points:
    28
    good work people.. just came across this thread..

    If you have a google around you will find there is a very very cutting edge release of x264 almost weekly.. always a little experimental, but can be useful for people with these peoblems.. as I say.. google for it.. because the location shifts regularly.. those proprietary h264 people don't like us doing it better for free :)
     

Share This Page