1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

uTorrent problems

Discussion in 'Windows - P2P software' started by djo90, Nov 19, 2007.

  1. djo90

    djo90 Member

    Joined:
    Nov 19, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Hey, I'm a bit new around here, and I've got a problem that I'm not sure how to fix. I've been using uTorrent for a while, and I've had a port forwarded for a long time. A few days ago I was getting extremely low download speeds for my seed/peer ratio (the ratio was something like 350 seeds, 20 peers); around 50-80kbs. Usually I'm getting much more than this, so I opened the uTorrent speed guide (uTorrent/options/speed guide) and ran the test to see if the port was forwarded properly. To my surprise, it said it did not appear to be open. I logged onto my router (a D-Link DI-524), and the port seemed to be open. Just to make sure, I tried opening another port; same thing happened. I went to portforward.com and followed their instructions on how to forward a port to the letter; uTorrent still says the port is not open. Any ideas on how to fix this? I've already set up a Static IP, so that cannot be the problem.
     
  2. LOCOENG

    LOCOENG Moderator Staff Member

    Joined:
    Feb 4, 2005
    Messages:
    11,493
    Likes Received:
    2
    Trophy Points:
    118
    Your IP could be throttling your downloads.
     
  3. svtstang

    svtstang Regular member

    Joined:
    Apr 23, 2006
    Messages:
    4,565
    Likes Received:
    0
    Trophy Points:
    46
    ISP's typcially throttle seeding activity, simply stating your ISP could clear that up quickly.

    Sounds like you did everything correctly, did you give utorrent proper permission in your firewall? What port are trying to forward?
     
  4. djo90

    djo90 Member

    Joined:
    Nov 19, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    I did give uTorrent permission in my firewall; I even went so far as to give the specific port I was using permission through the firewall. It's just some random port; it was my understanding that no port in particular is better than another. I just randomly chose one and stuck with it.

    Also, I'm terribly sorry but I'm not sure what you mean by stating my ISP. Is this something that I put into uTorrent?

    Thanks for the help guys, I appreciate it.
     
  5. svtstang

    svtstang Regular member

    Joined:
    Apr 23, 2006
    Messages:
    4,565
    Likes Received:
    0
    Trophy Points:
    46
    ISP = Internet Service Provider, some are known for traffic shaping.

    And by the way, not all ports are equal. Some ports are known for opening the door to trojans, here is a list: http://www.simovits.com/trojans/trojans.html

    Just don't forward any of those ports and you wont have to worry about it.

    You shouldn't have forwarding issues if you gave the port permission in both your firewall and router. If it is that bad, you can always post screen shots of your router/firewall settings and I could take a look for you.
     
    Last edited: Nov 20, 2007
  6. djo90

    djo90 Member

    Joined:
    Nov 19, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    One thing I've noticed is that when I log into my router and set the protocol type to TCP instead of "Both" (TCP & UDP), uTorrent immediately says the port is open. Why is that? I was under the impression that you needed the protocol type set to Both (that's what this guide at portforward.com said to do. It's a guide specifically for my router, so I was surprised that it didn't work when I followed its instructions to the letter.
     
  7. svtstang

    svtstang Regular member

    Joined:
    Apr 23, 2006
    Messages:
    4,565
    Likes Received:
    0
    Trophy Points:
    46
    UDP is not necessary for bittorent, you will not experience problems/issues if you chose not to forward the port using the UDP setting. Glad you figured our the problem!
     

Share This Page