1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VDub Help

Discussion in 'DivX / XviD' started by Lynx560, Jan 11, 2007.

  1. Lynx560

    Lynx560 Member

    Joined:
    Jan 11, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    I want to burn a vid I downloaded on to a CD to play on my TV.
    The vid is currently encoded with a Xvid codec [GSpot: Video Format: DivX Decoder filter (2x) & XviD MPEG-4 Video Decoder -- Audio Format: WAVE FORMAT MPEGLAYER3 (MP3) -->MPEG Layer-3 Decoder].
    I used TMPGEnc to reencode to .mpg but when I played it, the sound was way off (it was fine before as .avi).
    So... I opened VirtualDub to syncronize the audio, but when I opened the video file I got this error:
    "VirtualDub has detected an improper VBR audio encoding in the source AVI file and will rewrite the audio header with standard CBR values during processing for better compatability. This may introduce up to 9230 ms of skew from the video stream. If this is unacceptable, decompress the *entire* audio stream to an uncompressed WAV file and recompress it with a constant bitrate encoder. (bitrate 111.2 +/- 13.7 kbps)"
    Can anyone tell me what I need to do ? I already extracted the WAV file from the vid (using VDub File-Save WAV) but I dont know what to do next.
    Any help would be appreciated
    Thank you
     
  2. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    If the audio is off by a set amount (constant) after encoding, this should fix things. Run the origonal file through AviMux_Gui (it's free): http://www.alexander-noe.com/video/amg/ Drag and drop your file into the top window, highlight it and select "generate data". Now, in the lower window, highlight the audio and any delay will appear to the right in ms. If anything other than 0 appears, select start giving you the option of naming the new file as you wish and putting it where you wish and you will have a new file to encode in 1-2 minutes. The origonal wav should be fine to use, I always do this for AC3 audio and have never had a problem.
     
  3. Indochine

    Indochine Regular member

    Joined:
    Dec 21, 2006
    Messages:
    1,485
    Likes Received:
    0
    Trophy Points:
    46
    I've had this many a time. Can I ask a question? Is the audio off by about 9 seconds? Because 9230 ms is short for 9,230 milliseconds. (A millisecond is one thousandth of one second).

    Anyway, if you load the avi, click OK to the error message, and choose "save WAV" from the file menu, saving the audio to a WAV file (make up a suitable file name), you should be able to then goto the audio menu, choose "WAV audio", then a dialog will come up for you to choose a wav file, choose the file you just saved, then in the audio menu choose "compression", pick "no compression", again in the audio menu pick "interleaving", and enable it, then in the video menu pick "direct stream copy", finally you can save a new avi which should be OK.

    I have found that WinAVI can often deal with really obstinate AVI files sync problems that VirtualDub doesn't solve. I am not sure why.
     
  4. Lynx560

    Lynx560 Member

    Joined:
    Jan 11, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Thank you both...

    To mistycat: I am running Win98 & AviMux_Gui is not supported as stated on the web site. Any other ideas ?

    To Indochine: I followed all your directions but when I tried to save the file as a new AVI, I got this error message: No audio decompressor could be found to decompress the source audio format
    What do I do now ?

    Thank you !
     
  5. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    No, but I do know that Vdub gave me an error message that no xvid codec could be located when I had viewed and encoded hundreds of xvid's. A solution to that, for me, was to uninstall my codecs and start over with a different xvid codec. Maybe, use G Spot to find the audio codec and uninstall/reinstall it so that Vdub recognizes it. Or, try using the wav as the audio source in TMPGEnc and encode to CBR.
     
  6. Lynx560

    Lynx560 Member

    Joined:
    Jan 11, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    OK... I checked the file information using VDub & it said:
    Audio Stream
    Sampling rate: 48000Hz
    Channels: 2 (Stereo)
    Sample precision: 0-bit
    Compression: Unknown (tag 0055)
    Preload skew: 384 samples (0.03s)
    # of frames: 97947
    Min/avg/max/total frame size: 96/333/768 (31918K)


    G-Spot Info:
    Audio Format - Codec
    Name: 0x0055(MP3) ID'd as MPEG-1 Layer 3
    Stat: Codec is installed
    More: Audio Format
    Code: 0x0055
    Name: WAVE FORMAT MPEGLAYER3 (MP3)
    Vendor: ISO/MPEG
    Installed Codec: MPEG Layer-3 Decoder
    Bitrate: 112 kb/s (56/ch x 2ch)VBR LAME3.97b


    Also; the vid is encoded with XviD (DivX 5.2.1) but plays just fine, so its probably not a video codec problem. The vid is split into two parts using an unknown splitter. The second part has the same error screen but is 11601ms off.
    Perhaps the LAME codec is the problem... but I have no idea how to delete it as it's not listed in Add/Remove Programs.
    Also, it tested some other WAV files & they play just fine in WinAmp; but the WAV I extracted from the vid (31MB) will not.
    mistycat... I ran TMPGEnc with the extracted WAV file before & it was encoded to CBR but it didnt work.

    Any ideas ?
     
  7. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    No, sorry.
     

Share This Page