1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Very Noobish question but please help..!

Discussion in 'Sony PSP - Mod and firmware discussion' started by FrostX, Apr 4, 2007.

  1. FrostX

    FrostX Guest

    I have a PSP which had a v1.5 firmware, offcoarse as a newb I updated its firmware to 3.03 and now nothing works except the original PSP stuff, I tried downgrading it to 1.5 again but it said I needed an original GTA Liberty city story to make it work, so I tried 3.03 OE-C work dark-alex thing, I can't make it work....Please Help!!
     
  2. projectm

    projectm Member

    Joined:
    Apr 1, 2007
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    To use the custom firmware you must already be at 1.5. With 3.03 its still an easy downgrade all you need is an unpatched version of GTA:LCS just try and rent it.
     

Share This Page