1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Video Problem please help!!!!

Discussion in 'PC hardware help' started by NJman, Jun 1, 2007.

  1. NJman

    NJman Member

    Joined:
    Jan 16, 2006
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    16
    i just got a geforce 7900 GS. switched out my old PSU because it didnt have enough wattage or current. New PSU has 600W 12V 20A. When i turn on the PC everything runs just fine. Heres where the problem starts. When i try to run a low end game say like counter-strike 1.6 or starcraft it runs fine, picture and everything. When i try to run a more high end game such as Counter-strike source or HL2 my screen goes blank but i can still hear the background music. Currently im using the drivers that came with the GPU but im going to update with the lastest from the Nvidia site in the next few days. Any ideas on what might be causing the video problem?
     
  2. paztelu

    paztelu Regular member

    Joined:
    May 4, 2005
    Messages:
    371
    Likes Received:
    0
    Trophy Points:
    26
    Well, as you said first update the drivers, if possible post your full PC specs. Now, when the screen goes black, does the music just freezes in an infinite loop? or it goes normally, lets say in CS-Source, the screen goes blank, but you press the button to fire a weapon, do you hear how the game goes normally?

    Just to rule out overheating, do you have the correct air flow on your case? if possible report any temperature from the GPU.

    In the worst case it maybe that the card is faulty, it happens :( you would have to replace it. But for now try updating drivers, and checking air flow of your pc. Hoped it helped.
     
  3. marsey99

    marsey99 Regular member

    Joined:
    Aug 13, 2006
    Messages:
    1,398
    Likes Received:
    0
    Trophy Points:
    46
    i would guess that its your psu, i know its 600w but 20amps is the min req for that card. its quite possible that the psu only produces 20amps when your pc is drawing a very little amount of power from it, so when your system draw higher amounts like when your play cs:s the ampage drops and the gpu gets underpowered causing the black screens.


    try new drivers, 94.24 is the latest forceware, and you could rma your card but if its still the same after it has to be your psu.
     

Share This Page