1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Virtualdub error at the beginning of file creation

Discussion in 'Video - Software discussion' started by mathninja, Feb 21, 2004.

  1. mathninja

    mathninja Member

    Joined:
    Feb 21, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    http://www.afterdawn.com/guides/archive/dvd2divx_anamorphic.cfm

    I have been following along with this "how to" article on to rip a DVD to .avi format using the DivX encoder. With that posted article being a couple of years old now, I have had to do some troubleshooting - many of the programs listed are in newer versions, so the commands have changed slightly. Still, I think I managed to get to the final step fairly successfully - the step where VirtualDub actually is used to create the final product.

    When I put the two passes into the final job queue and click Start, there is an error - whose message is:


    Cannot Start Video Compression:

    The source image format is unacceptable.
    (error code -2)


    In an old forum message, the suggestion was made to ensure that the resolution was set to be multiples of 16, and I have done so, but without solving the problem.

    The one major difficulty I had was because I am using DivX Pro codec 5.1.1, not DivX 5.0, and the codec configuration menu is VERY different. I have tried my best to set the settings the same way as suggested in the article. Could these settings be causing this problem?

    Thanks in advance for any help you can give me with this.
     
  2. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    The Resolution setting are in Virtual-Dub"s Filters, not in the DivX Codec settings..so Make go to "Video" to "Filters" and Choose the "Resize" filter and set it to the Resolution you want to use...Cheers
     
  3. mathninja

    mathninja Member

    Joined:
    Feb 21, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Thanks - I didn't realize that the resize filter also needed to be set to a multiple of 16 - I increased the size to 640x488 to compensate and the file began the process okay - but I ran into another problem.

    The file doesn't seem to be compressing. 27% into the first pass I got an error message - low disk space - and when I checked the size of the file that was 27% created by that first pass, it was 28 gigs! This file should be much smaller, should it not?
     
  4. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Well I don"t use DivX much so I don"t know much about how it stores Information for the First Pass...Maybe Try useing the "First Pass Quality Based" setting instead of a Multi-Pass setting and see if you get acceptable Quality...But it does sound like there is something wrong because it shouldn"t take up that much space, Are you sure that you had Both Audio and Video set to "Full Proscessing
    Mode"??..And You don"t need to set the Resolution settings at all in the Codec settings cuz all of the Resizeing is Done with the Virtual-Dub Resize Filter...Cheers
    _X_X_X_X_X_[small]It"s better to be Pissed Off than Pissed On!!![/small]
     
    Last edited: Feb 23, 2004
  5. mathninja

    mathninja Member

    Joined:
    Feb 21, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Thanks Minion - it's all good, now. I had forgotten to turn on the compression when I last tried. The file turned out to still be bigger than I was expecting, but this problem was solved when I ripped the stereo audio track, rather than the surround audio track.

    Cheers - thanks for the help.
     

Share This Page