1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Vista LAN driver needed internet not working

Discussion in 'Windows - General discussion' started by Spider323, May 19, 2007.

  1. Spider323

    Spider323 Regular member

    Joined:
    Jan 18, 2004
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    26
    Hi, I just installed Windows Vista 32 bit yesterday and the problem I have is that the LAN driver that comes with windows won't work. I tried finding the LAN driver for my motherboard since the LAN is onboard but couldn't find anything for Vista. The motherboard I have is an Asrock dual-sata2. The weird thing is when I put my computer to sleep an awaken it the internet starts working for a little bit and drops again. Any help at all is greatly appreciated. Thanks.
     
  2. ddp

    ddp Moderator Staff Member

    Joined:
    Oct 15, 2004
    Messages:
    39,092
    Likes Received:
    84
    Trophy Points:
    128
  3. Spider323

    Spider323 Regular member

    Joined:
    Jan 18, 2004
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    26
    I already tried installing the Integrated220 driver before but unfortunately it did not work and I ended up just uninstalling it.
     
  4. borhan9

    borhan9 Active member

    Joined:
    May 25, 2005
    Messages:
    2,867
    Likes Received:
    1
    Trophy Points:
    68
    You should try going and updating the driver for your lan either from Device manager and updating it through there or through Windows Update.
     

Share This Page