1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem VLC media player not playing dvds

Discussion in 'Video playback problems' started by deezalboy, Aug 23, 2015.

  1. deezalboy

    deezalboy Regular member

    Joined:
    Dec 29, 2007
    Messages:
    266
    Likes Received:
    1
    Trophy Points:
    28
    The media player loads the dvd (see attached), in a small screen,not full, and when i click play feature, the bar at the bottom keeps going across and back. I tried Media player classic and it works perfectly. i`ve tried a few other dvds and they result in the same with Vlc media player. I reinstalled Vlc and there`s no change. Any ideas?
     

    Attached Files:

  2. scorpNZ

    scorpNZ Active member

    Joined:
    Mar 23, 2005
    Messages:
    3,974
    Likes Received:
    39
    Trophy Points:
    78
    Yeah that's vlc , sometimes mpc can have issues navigating dvd's as well on the odd occasion,just use mpc.If both have an issue playing i'll drop the vobs directly to the player tho that's from ripped dvd's.If you have the space convert the dvd's to a portable format like mkv,i realise it can be time consuming especially if you want to have the extra's as well however it makes it easier than changing dvd's.

    If vlc gives the track in the menu bar (sometimes the issue you describe this option can be grayed out),you may be able to navigate to the desired track,it's under the playback option
     
  3. deezalboy

    deezalboy Regular member

    Joined:
    Dec 29, 2007
    Messages:
    266
    Likes Received:
    1
    Trophy Points:
    28
    Found a fix as follows. VLC works fine now:D
    Reset preferences from VLC
    Using VLC within preferences
    If you can launch VLC, in the preferences dialog, from the Tools menu, you can hit the "Reset preferences" button.

    NB: This might not solve all your issues, all the time; so if you still have issues, then see the rest of this article.

    Reset preferences and cache
    Windows
    Using the shortcut in the start menu
    If you installed VLC properly you can delete the preferences and cache by simply opening the shortcut you can find in your start menu:

    All programs > VideoLAN > Reset VLC media player preferences and cache files

    Deleting the files manually
    Open the explorer and type %APPDATA% into the address bar and hit enter. This should lead you to the AppData folder of your user.

    Therein you should find a folder named vlc. Delete that folder and you're done.
     
  4. Nepheler

    Nepheler Member

    Joined:
    Dec 2, 2014
    Messages:
    80
    Likes Received:
    1
    Trophy Points:
    18
    Thanks for pointing it out deezalboy;)
     
  5. deezalboy

    deezalboy Regular member

    Joined:
    Dec 29, 2007
    Messages:
    266
    Likes Received:
    1
    Trophy Points:
    28
    Pleased to help
     
  6. ps355528

    ps355528 Regular member

    Joined:
    Aug 17, 2010
    Messages:
    996
    Likes Received:
    10
    Trophy Points:
    28
    even experts can screw up.. mine stopped playing dvd's a few weeks back.. on a rebuild I swapped the ide cables round.. leading to dev/dvd not pointing to the right place.. for some reason.. even though it's a symlink to /mnt/cdrom0 .. which is a symlink to /mnt/cdrom .. which is a symlink to /dev/sr0

    bloody linux.. simple cure.. change the mount point for /dev/sro to /dev/sr1 .. which is where it's ended up.. and is also a symlink to /dev/hdb ..

    even weirder.. dropping the ifo file into vlc played the whole disk as intended.. even though the mount points were completely wrong !!

    lesson?.. vlc "open disk" is picky about mountpoints
     

Share This Page