1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What firmware do i need?........help a newbie please

Discussion in 'Sony PSP - Mod and firmware discussion' started by jackass07, Jun 2, 2007.

  1. jackass07

    jackass07 Guest

    Hi all,

    I have a psp with firmware 3.03 oe-c. Lately i have had some new games which wont work. Both are giving me the same error message "The game could not be started - 80020148".
    The psp always has a UMD inserted. I've checked the memory card and that is working fine. I have also managed to get different versions of the games thinking that they might be bad rips, but i get the same problem.

    The games are: The Pirates of the Caribbean-At Worlds End & The Legend of the Dragon.

    Do i need to upgrade to 3.30 or 3.40 to be able to play these games.
    Thanks in advance
     
  2. mrmcman

    mrmcman Guest

    yes, i would say upgrade to 3.40 oe-a. it will be a lot easier for u in the long run
    just be sure to reset ur xmb to the original before u upgrade
     
  3. Megaman17

    Megaman17 Regular member

    Joined:
    Nov 13, 2006
    Messages:
    508
    Likes Received:
    0
    Trophy Points:
    26
    Go to recovery mode and switch kernels
    or Turn off NO UMD MODE

    To enter recovery mode:
    1. Fully turn off PSP
    2. Hold R shoulder buttton while booting PSP
    3. U will reach Recovery menu.
    4. Go to Configuration
    5. Change kernel to 3.03 OR Turn off NO UMD MODE.

    Try loading it.
     
  4. Megaman17

    Megaman17 Regular member

    Joined:
    Nov 13, 2006
    Messages:
    508
    Likes Received:
    0
    Trophy Points:
    26
    Y do u need to reset ur XMB?
    When u upgrade it will reflash all the files back.
     
  5. mrmcman

    mrmcman Guest

    just a precaution, i semi-bricked mine because i never reset my xmb, and i had to go thru the process again
     
  6. jackass07

    jackass07 Guest

    thanks guys for the advice
     

Share This Page