1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What firmware do I need?

Discussion in 'Xbox 360 - Modding & Hacking' started by jerecho, Dec 10, 2011.

  1. jerecho

    jerecho Regular member

    Joined:
    Nov 23, 2005
    Messages:
    695
    Likes Received:
    0
    Trophy Points:
    26
    I just tried to play Saints row 3 and my xbox said that the game needed to be updated but the update could not be found. I guess I need to update my firmware but haven't done it in quite awhile. I have a benq drive. Thanks
     
  2. arsenalforever

    arsenalforever Regular member

    Joined:
    Dec 4, 2011
    Messages:
    273
    Likes Received:
    0
    Trophy Points:
    26
    LT 3.0 will be out soon. Get it once it's out. Do you flash xbox yourself?
     
  3. jerecho

    jerecho Regular member

    Joined:
    Nov 23, 2005
    Messages:
    695
    Likes Received:
    0
    Trophy Points:
    26
    Ya. I flash it myself. I do it old school style though and don't use jungle flasher. I use dosflash32. I got the firmware "LT-Benq-0800-v3.bin"

    I was going to flash using that tomorrow. Will that not work? My box is banned and has been for years so I don't care about that. I just want the xdg3 discs to boot.

    Thanks
     
    Last edited: Dec 11, 2011
  4. funksoulb

    funksoulb Regular member

    Joined:
    Oct 4, 2008
    Messages:
    1,713
    Likes Received:
    0
    Trophy Points:
    46
    The 0800 V3 firmware is for flashing a 360 drive solely to use it for ripping games - not for playing them.

    What you need is LT+ 3.0 and it hasn't been released yet. If you're experienced with flashing and don't mind doing it twice in a short space of time, you could flash to LT+ 2.0 now, then go to 3.0 when it's released (which should be soon, but you never know). Just be wary of the AP2.5 situation (check the pinned thread at the very top of the page for more info), cos you'll be safer if you wait for LT+ 3.0.
     
  5. arsenalforever

    arsenalforever Regular member

    Joined:
    Dec 4, 2011
    Messages:
    273
    Likes Received:
    0
    Trophy Points:
    26
    wait for LT +3.0 to come out mate...
     
  6. jerecho

    jerecho Regular member

    Joined:
    Nov 23, 2005
    Messages:
    695
    Likes Received:
    0
    Trophy Points:
    26
    Thanks for the reply. I'll try the 2.0 firmware you mentioned

    is it this one? (LTPlus-benq-v2.0)

    Like I said I am already banned and don't mind flashing twice if I have to.


    Thanks again
     
    Last edited: Dec 11, 2011
  7. jerecho

    jerecho Regular member

    Joined:
    Nov 23, 2005
    Messages:
    695
    Likes Received:
    0
    Trophy Points:
    26
    I just flashed using the bin file "LTPlus-benq-v2.0" and I still get the error when the game tries to boot that says that the game requires an update that can not be found. Did I use the correct firmware?
     

Share This Page