1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What for i need gta:lcs to downgrade?

Discussion in 'Sony PSP - Mod and firmware discussion' started by Lauka, Jan 30, 2007.

  1. Lauka

    Lauka Member

    Joined:
    Jan 27, 2007
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    11
    Why don't i just downgrade mmy psp with no games ?
     
  2. Smurff

    Smurff Regular member

    Joined:
    Jun 12, 2005
    Messages:
    3,410
    Likes Received:
    0
    Trophy Points:
    46
    because gta:lcs w/ the 2.0 upgrade file on it has an exploit that is REQUIRED to downgrade ur psp. now quit asking dumb questions about do i need, why do i need, why not iso of game, etc. etc. and just buy/rent/borrow the damn thing and downgrade, or don't.

    that simple.

    (u could try to research before asking questions like this.)
     

Share This Page