1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What in the world.....

Discussion in 'PS2' started by flawlezz, Mar 11, 2005.

  1. flawlezz

    flawlezz Member

    Joined:
    Mar 7, 2005
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    16
    Okay, the first time I realized I was using the wrong disc but I reordered the Swap Magic Disc 3.3. The DVD version of the swap disc does not load at all. I'm thinking its the version 3.3. Both of these disc are blue. I'm thinking about ordering an earlier version where there is a white and blue disc, I forgot the version. Is anyone else experiencing any problems with their 3.3? Do you think I should order the earlier version?

    Or at least anwser me this: Do you know why my DVD Version of the Swap Disc always take me back to the browser screen?
     
  2. Jizmak

    Jizmak Regular member

    Joined:
    Dec 27, 2004
    Messages:
    2,584
    Likes Received:
    0
    Trophy Points:
    46
    You are using a slide card and/or slide tool or
    fliptop to switch the disks correct?

    You CANNOT press the eject button It will not work.

    You must have another method to open the tray.

     
  3. Prize99

    Prize99 Regular member

    Joined:
    Mar 5, 2005
    Messages:
    115
    Likes Received:
    0
    Trophy Points:
    26
    You can use the eject button to load the swap magic disc, it's after it tells u to "insert disc" then u have to use flip top or slide tool. The earlier version of swap magic u are reffering to is 2.0. My friend is having the same problem with his PS2 because it keeps taking him back to the browser screen and takes about 10 tries to load. In my opinion its not the discs that are messed up, its ur PS2. My friend has a V1 and his laser worn out. Try cleaning out the laser or replacing it.
     
  4. flawlezz

    flawlezz Member

    Joined:
    Mar 7, 2005
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    16
    No I'm not using the eject button I'm using the slide tool. When I try to load the DVD version of the damn thing it don't work at all. I do remember one time though the "Playstation 2" sign came up only for half a second and it sent me right back to the browser. I tried TWO different DVD disc and it still didn't work. So I dont know whats wrong....
     

Share This Page