1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

what is the best firmware to use?

Discussion in 'Sony PSP - Mod and firmware discussion' started by shinobi76, Jul 31, 2007.

  1. shinobi76

    shinobi76 Member

    Joined:
    Jul 30, 2007
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    11
    Total noob here. Been reading around for the best solution to upgrade/downgrade my firmware. There seem to be so many different options, that I'm abit confused.

    1. Which firmware is considered the best to have right now, one that can run the most application, etc?

    2. I currently have firmware 1.52, how would I get to the firmware that you answered in question 1?

    thanks
     
  2. glenquag

    glenquag Regular member

    Joined:
    Mar 7, 2007
    Messages:
    1,879
    Likes Received:
    0
    Trophy Points:
    46
    You could use the 2.00/.01 downgrader. Get it here
    But first you will need to update to 2.01, so download that here
    Download the 2.01 update, unzip/rar it and rename it to EBOOT.PBP and place it in your memory stick like this; PSP/GAME/UPDATE/(put it here). Follow all the readme's and read them correctly. once you downgrade you will be at 1.5, then you will need to update to a custom firmware, like 3.52 M33. With this firmware you can play homebrew, ISO's, PSX games, and customize your home menu. Download that here
    Then download update #2 here
    Once you've done all that you're set.
     
  3. PeaInAPod

    PeaInAPod Active member

    Joined:
    Nov 28, 2005
    Messages:
    3,065
    Likes Received:
    0
    Trophy Points:
    66
    Wow haven't seen people with that firmware in years! How long have you had your PSP?
     
  4. shinobi76

    shinobi76 Member

    Joined:
    Jul 30, 2007
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    11
    I know I've had mine couple of months after it came out. Anyways, I've tried upgrading to 2.00 or 2.01 and both times I am getting "The game could not be started" (80020148). What am I doing wrong? and no there is no umd disc inserted.
     
  5. bu22ard

    bu22ard Regular member

    Joined:
    Jul 16, 2006
    Messages:
    650
    Likes Received:
    0
    Trophy Points:
    26
    this should work perfectly...not sure why you are getting that error
     
  6. PeaInAPod

    PeaInAPod Active member

    Joined:
    Nov 28, 2005
    Messages:
    3,065
    Likes Received:
    0
    Trophy Points:
    66
    The problem is the file must be named "UPDATE.PBP" without the quotes.
     
  7. glenquag

    glenquag Regular member

    Joined:
    Mar 7, 2007
    Messages:
    1,879
    Likes Received:
    0
    Trophy Points:
    46
    What are you talking about? It's supposed to get named EBOOT.PBP and that's a fact. UPDATE.PBP is for when you downgrade.
     
  8. PeaInAPod

    PeaInAPod Active member

    Joined:
    Nov 28, 2005
    Messages:
    3,065
    Likes Received:
    0
    Trophy Points:
    66
    Your right, sorry bout that.
     

Share This Page